Skip to content

Commit

Permalink
dev-vcs/python-gitlab: 1.9.0 bump
Browse files Browse the repository at this point in the history
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
william-hubbs authored and williamh committed Jun 26, 2019
1 parent dc5c06f commit f734f6e
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/python-gitlab/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST python-gitlab-1.7.0.tar.gz 110657 BLAKE2B 1003d3373d3ef5474b1d5c10b1c6af57e7467cec432fc1eb75b4e1ba7766361641f25461ac2bf1b7692dab855d4e5cbc204240ede3568e71ed1af75682807fb0 SHA512 ad50d989e27948ff5188f4191ad3b7f1e1b45608627b2042bf02d635b2aa8da0a24f6b0383f483a01df54e4ab14576e7e4252576b9c2bdf67a187ae6aad69d53
DIST python-gitlab-1.8.0.tar.gz 115603 BLAKE2B 8ebebc1735e5531b4f95d82122b6ecf78fd541bce503f0cdf8c47b2ec2edab89efcad6c0ab39d82b57ffb8c3e341cb2160916b7df6c4886465e90557db3141c3 SHA512 4843aefb7cd363520e9065cfc08b81ec2c5c2c9cbdb5d6adbd35ec0f615bafd40e66746739c910b5e7e041f06e2aa9dc8beb8a884a714e6837cd5fb6fefb53be
DIST python-gitlab-1.9.0.tar.gz 116460 BLAKE2B f0a0d9679e4e742d966c678f8dcc6b2464e5ae8a013038221b3c484e6bb6ae23c166f82fec85c3560ebbce3cf80bc23657b1b906d8c6f284a64589545acdb035 SHA512 cb0d58896f55837f7088ab08551f2e9f9f82e8a04c19979a69bc042c95cdb2d04174dec49a236ddcf1344c50e9ffc6f929750b008bf6e619225c80bf9490afaa
41 changes: 41 additions & 0 deletions dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{5,6} )

if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64"
fi

inherit distutils-r1

DESCRIPTION="Python command line interface to gitlab API"
HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"

LICENSE="LGPL-3"
SLOT="0"
IUSE="test"

BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/testrepository[${PYTHON_USEDEP}]
dev-python/hacking[${PYTHON_USEDEP}]
dev-python/httmock[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.3
dev-python/sphinx_rtd_theme )"

RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"

python_install_all() {
distutils-r1_python_install_all
dodoc -r *.rst docs
}

0 comments on commit f734f6e

Please sign in to comment.