Skip to content

Commit

Permalink
dev-util/boost-build: add 1.79.0
Browse files Browse the repository at this point in the history
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Apr 15, 2022
1 parent bb044a3 commit f75dc5d
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/boost-build/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST boost_1_77_0.tar.bz2 110361537 BLAKE2B 106aeb09ec7705b595f2ca966a76c53c649eac6fac50d88c156862e0991c33c89a2f3a09edcbcb453fa44bf71cdde030b35d0a0889ad97b65f3a868cb877a532 SHA512 39b45c9b60bc5a2a4c669a4463d1272c1e093376b2fb374d7f20a84ea10a3e23bb04b335a735a83a04575731f874d9bff77e89acd947524b3fbbae1b26ae1f2f
DIST boost_1_78_0.tar.bz2 110675550 BLAKE2B ed7da98862ec1e0a28472544400e6f44ffadbc967eed969ce6cb62b1c4f0b7a4b98a395269eb374b57326eff9cdb1dd6e47df9d1a9730aff7c926cc44388fb2d SHA512 9c34a387a203b99aa773eb0c59f5abac7a99ba10e4623653e793c1d5b29b99b88e0e4e0d4e2e4ca5d497c42f2e46e23bab66417722433a457dc818d7670bcbbf
DIST boost_1_79_0.tar.bz2 113456811 BLAKE2B 61f47ca022e60745868e6bdd3b5c75603dd68d878e126dcbb73de5b40fc03c0eec8eede3ec304ece58050435ef2fc1ed7eb763773c20673f85e32bbf4d5f978a SHA512 70909e0561c213d10a1fdd692f9ae7b293d3cdc63e925bdc207da9e9bba6e86474341100e7ee5de6d94f9561196b1a3a1597055a7b7382babf8931131170a312
73 changes: 73 additions & 0 deletions dev-util/boost-build/boost-build-1.79.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit flag-o-matic toolchain-funcs

MY_PV="$(ver_rs 1- _)"

DESCRIPTION="A system for large project software construction, simple to use and powerful"
HOMEPAGE="https://www.boost.org/build/"
SRC_URI="https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/boost_${MY_PV}.tar.bz2"
S="${WORKDIR}/boost_${MY_PV}/tools/build/src"

LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples"
RESTRICT="test"

PATCHES=(
"${FILESDIR}"/${PN}-1.71.0-disable_python_rpath.patch
"${FILESDIR}"/${PN}-1.78.0-darwin-gentoo-toolchain.patch
"${FILESDIR}"/${PN}-1.73.0-add-none-feature-options.patch
"${FILESDIR}"/${PN}-1.76.0-respect-user-flags.patch
"${FILESDIR}"/${PN}-1.78.0-no-implicit-march-flags.patch
)

src_unpack() {
tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
}

src_prepare() {
default

pushd .. >/dev/null || die
eapply "${FILESDIR}"/${PN}-1.71.0-fix-test.patch
popd >/dev/null || die
}

src_configure() {
# need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
append-lfs-flags
}

src_compile() {
cd engine || die
${CONFIG_SHELL:-${BASH}} ./build.sh cxx --cxx="$(tc-getCXX)" --cxxflags="${CXXFLAGS}" -d+2 --without-python || die "building bjam failed"
}

src_test() {
# Forget tests, bjam is a lost cause
:
}

src_install() {
dobin engine/{bjam,b2}

insinto /usr/share/boost-build/src
doins -r "${FILESDIR}/site-config.jam" \
../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
build kernel options tools util

find "${ED}"/usr/share/boost-build/src -iname '*.py' -delete || die

dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt

if use examples; then
docinto examples
dodoc -r ../example/.
docompress -x /usr/share/doc/${PF}/examples
fi
}

0 comments on commit f75dc5d

Please sign in to comment.