Skip to content

Commit

Permalink
dev-util/geany: Added live ebuild. Thanks to Kristoffer Bernssen.
Browse files Browse the repository at this point in the history
  • Loading branch information
Kristoffer Bernssen authored and Lars Wendler committed Feb 16, 2018
1 parent cf70391 commit f77bc32
Showing 1 changed file with 67 additions and 0 deletions.
67 changes: 67 additions & 0 deletions dev-util/geany/geany-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools eutils fdo-mime gnome2-utils

LANGS="ar ast be bg ca cs de el en_GB es et eu fa fi fr gl he hi hu id it ja kk ko lb lt mn nl nn pl pt pt_BR ro ru sk sl sr sv tr uk vi zh_CN ZH_TW"
NOSHORTLANGS="en_GB zh_CN zh_TW"

DESCRIPTION="GTK+ based fast and lightweight IDE"
HOMEPAGE="http://www.geany.org"
EGIT_REPO_URI="https://github.com/geany/geany.git"
inherit git-r3
SRC_URI=""
LICENSE="GPL-2+ HPND"
SLOT="0"

KEYWORDS=""
IUSE="gtk3 +vte"

RDEPEND=">=dev-libs/glib-2.32:2
!gtk3? (
>=x11-libs/gtk+-2.24:2
vte? ( x11-libs/vte:0 )
)
gtk3? (
>=x11-libs/gtk+-3.0:3
vte? ( x11-libs/vte:2.91 )
)"
DEPEND="${RDEPEND}
virtual/pkgconfig
dev-util/intltool
sys-devel/gettext"

pkg_setup() {
strip-linguas ${LANGS}
}

src_prepare() {
default
[[ ${PV} = *_pre* || ${PV} = 9999 ]] && eautoreconf
}
src_configure() {
econf \
--disable-html-docs \
--disable-dependency-tracking \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable gtk3) \
$(use_enable vte)
}

src_install() {
emake DESTDIR="${D}" install
prune_libtool_files --all
}

pkg_preinst() { gnome2_icon_savelist; }

pkg_postinst() {
fdo-mime_desktop_database_update
gnome2_icon_cache_update
}

pkg_postrm() {
fdo-mime_desktop_database_update
gnome2_icon_cache_update
}

0 comments on commit f77bc32

Please sign in to comment.