forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: David Seifert <[email protected]>
- Loading branch information
1 parent
32179e6
commit f78117d
Showing
2 changed files
with
11 additions
and
9 deletions.
There are no files selected for viewing
14 changes: 8 additions & 6 deletions
14
app-cdr/b5i2iso/b5i2iso-0.2-r1.ebuild → app-cdr/b5i2iso/b5i2iso-0.2-r2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,24 +1,26 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
EAPI=8 | ||
|
||
inherit toolchain-funcs | ||
|
||
DESCRIPTION="Convert CD images from b5i (BlindWrite) to iso" | ||
HOMEPAGE="https://web.archive.org/web/20100116120705/b5i2iso.berlios.de" | ||
SRC_URI="mirror://gentoo/${P}.tar.bz2" | ||
S="${WORKDIR}/${PN}" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos" | ||
PATCHES=( "${FILESDIR}/${P}-segfault.patch" ) | ||
|
||
S=${WORKDIR}/${PN} | ||
PATCHES=( "${FILESDIR}"/${P}-segfault.patch ) | ||
|
||
src_compile() { | ||
$(tc-getCC) ${LDFLAGS} ${CFLAGS} src/${PN}.c -o ${PN} | ||
tc-export CC | ||
emake -C src b5i2iso | ||
} | ||
|
||
src_install() { | ||
dobin ${PN} | ||
dobin src/b5i2iso | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters