Skip to content

Commit

Permalink
app-emulation/qtrvsim: ensure Qt6 build
Browse files Browse the repository at this point in the history
Thanks to asturm for assistance with this.

Closes: https://bugs.gentoo.org/933594
Signed-off-by: Florian Schmaus <[email protected]>
  • Loading branch information
Flowdalic committed Jul 7, 2024
1 parent 8583fff commit f78a0f7
Showing 1 changed file with 33 additions and 0 deletions.
33 changes: 33 additions & 0 deletions app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="RISC-V CPU simulator for education"
HOMEPAGE="https://github.com/cvut/qtrvsim"
SRC_URI="https://github.com/cvut/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"

DEPEND="
dev-qt/qtbase:6[gui,widgets]
virtual/libelf:=
"
RDEPEND="${DEPEND}"

CMAKE_SKIP_TESTS=(
# Fails in 0.9.7, but not in master.
cli_stalls
)

src_prepare() {
cmake_src_prepare

# ensure Qt6 build
sed "/^ *find_package.*QT NAMES/s/Qt5 //" \
-i CMakeLists.txt || die
}

0 comments on commit f78a0f7

Please sign in to comment.