forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/qtrvsim: ensure Qt6 build
Thanks to asturm for assistance with this. Closes: https://bugs.gentoo.org/933594 Signed-off-by: Florian Schmaus <[email protected]>
- Loading branch information
Showing
1 changed file
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 2023-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit cmake | ||
|
||
DESCRIPTION="RISC-V CPU simulator for education" | ||
HOMEPAGE="https://github.com/cvut/qtrvsim" | ||
SRC_URI="https://github.com/cvut/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3+" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
DEPEND=" | ||
dev-qt/qtbase:6[gui,widgets] | ||
virtual/libelf:= | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
CMAKE_SKIP_TESTS=( | ||
# Fails in 0.9.7, but not in master. | ||
cli_stalls | ||
) | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
|
||
# ensure Qt6 build | ||
sed "/^ *find_package.*QT NAMES/s/Qt5 //" \ | ||
-i CMakeLists.txt || die | ||
} |