Skip to content

Commit

Permalink
mail-filter/milter-regex: fix build w/ Clang 16
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/871366
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Oct 1, 2022
1 parent 8a96bb4 commit f78f4ec
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
https://bugs.gentoo.org/871366
--- a/eval.h
+++ b/eval.h
@@ -107,4 +107,6 @@ struct action *eval_end(struct ruleset *, int *, int, int);
void eval_clear(struct ruleset *, int *, int);
void free_ruleset(struct ruleset *);

+int yylex(void);
+
#endif
47 changes: 47 additions & 0 deletions mail-filter/milter-regex/milter-regex-2.7-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="A milter-based regular expression filter"
HOMEPAGE="https://www.benzedrine.ch/milter-regex.html"
SRC_URI="https://www.benzedrine.ch/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="acct-user/milter-regex
>=mail-filter/libmilter-1.0.2_p2:="
DEPEND="${RDEPEND}
virtual/yacc"

src_prepare() {
eapply "${FILESDIR}/${PN}-2.6-gentoo.patch"
eapply "${FILESDIR}"/milter-regex-2.7-implicit-func-decl.patch
eapply_user
# Change default user
sed -i -e 's/_\(milter-regex\)/\1/g' ${PN}.[8c] || die
}

src_compile() {
emake CC="$(tc-getCC)" -f Makefile.linux all
}

src_install() {
dobin ${PN}
insinto /etc
newins rules ${PN}.conf
newconfd "${FILESDIR}/${PN}-conf-2.6" ${PN}
newinitd "${FILESDIR}/${PN}-init" ${PN}
doman *.8
}

pkg_postinst() {
elog "Postfix configuration example (add to main.cf or master.cf):"
elog " smtpd_milters=unix:/run/milter-regex/socket"
elog "Sendmail configuration example:"
elog " INPUT_MAIL_FILTER(\`${PN}',\`S=unix:/run/milter-regex/socket,T=S:30s;R:2m')"
}

0 comments on commit f78f4ec

Please sign in to comment.