Skip to content

Commit

Permalink
games-fps/gzdoom: Version bump to 4.7.0
Browse files Browse the repository at this point in the history
The gles2, telemetry, and vulkan USE flags are introduced.

Closes: https://bugs.gentoo.org/815274
Signed-off-by: William Breathitt Gray <[email protected]>
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
vilhelmgray authored and chewi committed Oct 9, 2021
1 parent 9993ebb commit f7e4330
Show file tree
Hide file tree
Showing 3 changed files with 89 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-fps/gzdoom/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gzdoom-4.6.0.tar.gz 13921655 BLAKE2B acf3273d53f24a1d65a1d7cd1614589699926211370e84570062464d989adc7a0427423ea3444db37a9c6393d3fee971db84c9a2c4346b5677906dd89d926af4 SHA512 d7c1f5155c1262e79c812983cac3856b917f5861f9ead0b9a307040f99802a489c3f836ed23baae245122971fa4fed872202131c8c8cf17724cf4e9b2b4efea5
DIST gzdoom-4.6.1.tar.gz 13937864 BLAKE2B 59ea057b42058944566a66c21f441752bd014235ac4644f9b50182673856fedc33414cbe12505a294842e46c93faaf120d844ccd49fb9afeede67640feab3764 SHA512 cec64f4f6a3be3693b35d716a44930cfa9fd10b794b380cf0ea624e7901f78f3e5211b17a0905b65de367fa62046cd6ebd099f5300c7f49e1c020faaae15dd41
DIST gzdoom-4.7.0.tar.gz 14070204 BLAKE2B 4cf0555e7d1e34f71057502bce0973d49ffca6bccd2396faee6360832511b90450008c4ec22a0cdadfa3edcd13ec73bf412c0af7c6298c560c087f8a3d5f0bdb SHA512 539d1de85b3e2313e57fc8fcb0fa4b7a5110107f5436ee3412342c1140cebbe4ccec45efa3211b43aba8bc3715ce0e7819dd593f55d8ee906f2382573435361f
DIST widepix-d458411.tar.gz 2542783 BLAKE2B 622355d61c102cf71f724ed709b80ba6ba652905fb806bfd6dad6a0944eabd3bac71c7fdad17354af17493f64d6418e93eef37c032e85615dffa27f9e8faa97f SHA512 fe8a243e2dbe6330121bf139e310baf677ec4803d6b0ecd24a93792a2f7071ba739b1c038ca7aa7eeafcc83bf57c8a009189a90e3115305967ba23b675c96543
86 changes: 86 additions & 0 deletions games-fps/gzdoom/gzdoom-4.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake desktop xdg flag-o-matic

WIDEPIX_COMMIT="d458411db4795dfd1420cf1c6456f6d2999b3bad"
DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
HOMEPAGE="https://zdoom.org"
SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz
non-free? ( https://github.com/nashmuhandes/WidePix/archive/${WIDEPIX_COMMIT}.tar.gz -> widepix-${WIDEPIX_COMMIT:0:7}.tar.gz )"

LICENSE="Apache-2.0 BSD BZIP2 GPL-3 LGPL-2.1+ LGPL-3 MIT
non-free? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist WidePix )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="debug gles2 gtk +non-free openmp telemetry vulkan"

DEPEND="
app-arch/bzip2
media-libs/libsdl2[gles2?,opengl,vulkan?]
media-libs/openal
media-libs/zmusic
sys-libs/zlib
virtual/jpeg:0
gtk? ( x11-libs/gtk+:3 )"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${PN}-g${PV}"

PATCHES=(
"${FILESDIR}/${PN}-4.5.0-Introduce-the-BUILD_NONFREE-option.patch"
)

src_prepare() {
rm -rf docs/licenses || die
rm -rf libraries/{bzip2,jpeg,zlib} || die
if ! use non-free ; then
rm -rf wadsrc_bm wadsrc_extra wadsrc_widescreen || die
else
mv "${WORKDIR}/WidePix-${WIDEPIX_COMMIT}/filter" wadsrc_widescreen/static/ || die
fi

cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DINSTALL_DOCS_PATH="${EPREFIX}/usr/share/doc/${PF}"
-DINSTALL_PK3_PATH="${EPREFIX}/usr/share/doom"
-DINSTALL_SOUNDFONT_PATH="${EPREFIX}/usr/share/doom"
-DDYN_OPENAL=OFF
-DNO_GTK="$(usex !gtk)"
-DNO_OPENAL=OFF
-DHAVE_VULKAN="$(usex vulkan)"
-DHAVE_GLES2="$(usex gles2)"
-DNO_OPENMP="$(usex !openmp)"
-DBUILD_NONFREE="$(usex non-free)"
)

use debug || append-cppflags -DNDEBUG
use telemetry || append-cppflags -DNO_SEND_STATS

cmake_src_configure
}

src_install() {
newicon src/posix/zdoom.xpm "${PN}.xpm"
make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
cmake_src_install
}

pkg_postinst() {
xdg_pkg_postinst

if ! use non-free ; then
ewarn
ewarn "GZDoom installed without non-free components."
ewarn "Note: The non-free game_support.pk3 file is needed to play"
ewarn " games natively supported by GZDoom."
ewarn "A list of games natively supported by GZDoom is available"
ewarn "on the ZDoom wiki: https://zdoom.org/wiki/IWAD"
ewarn
fi
}
2 changes: 2 additions & 0 deletions games-fps/gzdoom/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,9 @@
<name>Gentoo Games Project</name>
</maintainer>
<use>
<flag name="gles2">Enable GLES2 backend</flag>
<flag name="non-free">Enable non-free components</flag>
<flag name="vulkan">Enable Vulkan support</flag>
</use>
<upstream>
<bugs-to>https://forum.zdoom.org/viewforum.php?f=2</bugs-to>
Expand Down

0 comments on commit f7e4330

Please sign in to comment.