Skip to content

Commit

Permalink
sys-fs/btrfs-progs: Bump to version 4.19.1_rc1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Dec 3, 2018
1 parent 37c6b77 commit f81ec58
Show file tree
Hide file tree
Showing 2 changed files with 118 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/btrfs-progs/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@ DIST btrfs-progs-v4.14.1.tar.xz 1926492 BLAKE2B 35575946c1de9cb81f1aed2a5be24331
DIST btrfs-progs-v4.15.1.tar.xz 1931820 BLAKE2B 00c4b9f6ec2039ad680cd625e5ece1cd306b8eaa4572f262cd2272c9d1e03923834ec7af7e59afc9e931cf95d224aea883cc544ba8e26de03119d85c67f19b64 SHA512 6e6a9799f6716bbf772d5f0c8069579815060db20d30807e12948e7274448bca09a12c385ea05a95afc23722d12067a8d99623ea0091dca8ae75ea646aa84b88
DIST btrfs-progs-v4.16.1.tar.xz 1980696 BLAKE2B 85854fd025c92bd31c957623b78ad72efd536fc8c9d72cc7ad65b9a435b3d57405208e355a86d95ea46ed0179a04e34c3693c4e465e7d6a8edfacdbd185e1421 SHA512 9f0e8c593a10c1c09749ccc00f470ba44d4357fabca8d89ce5891ab0d9cd70f1356f1c6677288019387a6b3b3746431537da205627791a35955bb8bed33d807e
DIST btrfs-progs-v4.17.1.tar.xz 2045192 BLAKE2B cfc696f32ae8f02865206ff0b1f749a5af072b147537e2c6389a4fb7e93e437754b6af23f122722837612a08d86485bcf110e069facb6c5b76f193dc89a6d433 SHA512 90f291e362b640a22b41036351619e7b8a793a3b57d0537e7865edf4b830d6dc57b3051c0aed9e1ff38b602441a20fea7f974ccff789a3b4a622a0ea57756538
DIST btrfs-progs-v4.19.1-rc1.tar.xz 2006992 BLAKE2B 4280bb5e2c106023208df1a085e669b783beda82d26956311d7dbd3e33c804b12ebf27ebdb21261146f57ea202ad704b94e1ab8dba941d01ed58dc711e1f3669 SHA512 e79e5f25629fb83d0143dec460552e694fa9b3babf76c3e9dd17fa3ac6ea1095efe6f225918c6bbd56dfcb2bd1b800a8aeda95dd0ee20e1b6becefc632187672
DIST btrfs-progs-v4.19.tar.xz 2001340 BLAKE2B 117087adcb57e4ebf6a2e9c66bf0ad2b098108f7363fc3c015d73bf9afcda9d579831fe0e324125893cdb2510873d052522b15843c461e640a546900e535ce76 SHA512 e5abf637a9c811973422ca05a5530f6cd18263013d141277e2a70099cf8ab7e0eb8781df56368da4321c90f21d1022ad852b661adc4877e9a9ba5c60ccbefdee
DIST btrfs-progs-v4.4.1.tar.xz 1173248 BLAKE2B 8bf07a3bc3d24a3f641c2dc7a6353f186ebd98f7a633bdbc2689359e6204b3f1db76accee3e648634f319e26b57e6376c13fa31d39413908d0b2308e0ae28d0e SHA512 3086e2e0385d9e14edcfa25e1aee1ed98087dd5b91a66aa450786c932d79841b5c4ee3f9a40b8fdecee0ba1e386196b89679d28e58e4924ce66cd78c5e3c0d4a
DIST btrfs-progs-v4.9.1.tar.xz 1476524 BLAKE2B 3fdd1c040fdf8083fcf5d4106db22112aaba59dd9a6ab8ad164302ec153a83151fbf88d84181dc849c296bb96ad883d4f7329bff111c67c19fdb814db5073fb2 SHA512 143f5c8863f3b9eff2e4ca2c750bb80ffe62f66d0c15d23e6f5bf75dab0133dcd3ff4d4c722360560de24b73e3da1222f265230d18de06d7bccd85ad2cb9a6a5
117 changes: 117 additions & 0 deletions sys-fs/btrfs-progs/btrfs-progs-4.19.1_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,117 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python3_{4,5,6,7} )

inherit bash-completion-r1 python-single-r1

libbtrfs_soname=0

if [[ ${PV} != 9999 ]]; then
MY_PV="v${PV/_/-}"
[[ "${PV}" = *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="https://www.kernel.org/pub/linux/kernel/people/kdave/${PN}/${PN}-${MY_PV}.tar.xz"
S="${WORKDIR}"/${PN}-${MY_PV}
else
WANT_LIBTOOL=none
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/kdave/btrfs-progs.git"
EGIT_BRANCH="devel"
fi

DESCRIPTION="Btrfs filesystem utilities"
HOMEPAGE="https://btrfs.wiki.kernel.org"

LICENSE="GPL-2"
SLOT="0/${libbtrfs_soname}"
IUSE="+convert python reiserfs static static-libs +zstd"

RESTRICT=test # tries to mount repared filesystems

RDEPEND="
dev-libs/lzo:2=
sys-apps/util-linux:0=[static-libs(+)?]
sys-libs/zlib:0=
convert? (
sys-fs/e2fsprogs:0=
sys-libs/e2fsprogs-libs:0=
reiserfs? (
>=sys-fs/reiserfsprogs-3.6.27
)
)
python? ( ${PYTHON_DEPS} )
zstd? ( app-arch/zstd:0= )
"
DEPEND="${RDEPEND}
convert? ( sys-apps/acl )
>=app-text/asciidoc-8.6.0
app-text/docbook-xml-dtd:4.5
app-text/xmlto
python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
static? (
dev-libs/lzo:2[static-libs(+)]
sys-apps/util-linux:0[static-libs(+)]
sys-libs/zlib:0[static-libs(+)]
convert? (
sys-fs/e2fsprogs:0[static-libs(+)]
sys-libs/e2fsprogs-libs:0[static-libs(+)]
reiserfs? (
>=sys-fs/reiserfsprogs-3.6.27[static-libs(+)]
)
)
zstd? ( app-arch/zstd:0[static-libs(+)] )
)
"

if [[ ${PV} == 9999 ]]; then
DEPEND+=" sys-devel/gnuconfig"
fi

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
default
if [[ ${PV} == 9999 ]]; then
AT_M4DIR=m4 eautoreconf
mkdir config || die
local automakedir="$(autotools_run_tool --at-output automake --print-libdir)"
[[ -e ${automakedir} ]] || die "Could not locate automake directory"
ln -s "${automakedir}"/install-sh config/install-sh || die
ln -s "${EPREFIX}"/usr/share/gnuconfig/config.guess config/config.guess || die
ln -s "${EPREFIX}"/usr/share/gnuconfig/config.sub config/config.sub || die
fi
}

src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}"/sbin
$(use_enable convert)
$(use_enable elibc_glibc backtrace)
$(use_enable python)
$(use_enable static-libs static)
$(use_enable zstd)
--with-convert=ext2$(usex reiserfs ',reiserfs' '')
)
econf "${myeconfargs[@]}"
}

src_compile() {
emake V=1 all $(usev static)
}

src_install() {
local makeargs=(
$(usex python install_python '')
$(usex static install-static '')
)
emake V=1 DESTDIR="${D}" install "${makeargs[@]}"
newbashcomp btrfs-completion btrfs
use python && python_optimize
}

0 comments on commit f81ec58

Please sign in to comment.