forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-action/extreme-tuxracer: add 0.8.4
Signed-off-by: Michael Mair-Keimberger <[email protected]> Closes: gentoo#37445 Signed-off-by: Conrad Kostecki <[email protected]>
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST extreme-tuxracer-0.8.2.tar.xz 40828312 BLAKE2B dfc550457ac37f4aa0c649e1368610eb417e450eea454ed20dd57d7799f376714531861da69683ea1437f222ebd18acd8ccb14c5ce97c9225185d5bf6c8ef49d SHA512 572b494e82f00853b38b3913f0ef34d0a5c0b6655626fa6c72c76f7a41f723ff6fc3c20ca54d835ed5dba462f22896882e9c37ddf5b3e840ea14af3d336addb8 | ||
DIST extreme-tuxracer-0.8.4.tar.xz 40862904 BLAKE2B 4e49f2d3912a91bb9866a42361e919c474c4e9190bae3b6eaa1d568e628958c3aaf735a190128ca4335a40220f6d15186c515c93a7eaa7f17121a81a826feb20 SHA512 65d54bfef59cf83eec9ee761ac24c728d3118cf47105920f22057b59425eba65e03967196d4a93039f30b9420e67b10f296ec7deed7e506ad78c7bb5ce5ed0d2 |
38 changes: 38 additions & 0 deletions
38
games-action/extreme-tuxracer/extreme-tuxracer-0.8.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit autotools desktop xdg | ||
|
||
DESCRIPTION="High speed arctic racing game based on Tux Racer" | ||
HOMEPAGE="https://sourceforge.net/p/extremetuxracer/wiki/Home/" | ||
SRC_URI="https://download.sourceforge.net/extremetuxracer/etr-${PV}.tar.xz -> ${P}.tar.xz" | ||
S="${WORKDIR}/etr-${PV/_/}" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86" | ||
|
||
RDEPEND=" | ||
>=media-libs/libsfml-2.4:0= | ||
virtual/glu | ||
virtual/opengl | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
default | ||
# kind of ugly in there so we'll do it ourselves | ||
sed -i -e '/SUBDIRS/s/resources doc//' Makefile.am || die | ||
eautoreconf | ||
} | ||
|
||
src_install() { | ||
default | ||
dodoc doc/{code,courses_events,guide,score_algorithm} | ||
doicon -s 64 resources/etr.png | ||
doicon -s scalable resources/etr.svg | ||
domenu resources/net.sourceforge.extremetuxracer.desktop | ||
} |