Skip to content

Commit

Permalink
app-text/searchmonkey: Fix building with GCC-6 and EAPI bump
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/show_bug.cgi?id=602166
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Closes: gentoo#5260
  • Loading branch information
Peter-Levine authored and SoapGentoo committed Aug 13, 2017
1 parent ac45361 commit f89080a
Show file tree
Hide file tree
Showing 3 changed files with 63 additions and 2 deletions.
14 changes: 14 additions & 0 deletions app-text/searchmonkey/files/searchmonkey-2.0.0-gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
Bug: https://bugs.gentoo.org/602166

diff -Naur a/mainwindow.cpp b/mainwindow.cpp
--- a/mainwindow.cpp 2017-07-31 18:06:33.206668001 -0400
+++ b/mainwindow.cpp 2017-07-31 18:07:09.685940997 -0400
@@ -781,7 +781,7 @@
******************************************************************************/
void MainWindow::find () throw() {

- auto autoSettingsReset asr(sui); // dtor calls sui->reset()
+ autoSettingsReset asr(sui); // dtor calls sui->reset()

bool modeAdvanced = ui->actionAdvanced->isChecked();
qDebug() << "modeAdvanced-" << modeAdvanced;
44 changes: 44 additions & 0 deletions app-text/searchmonkey/searchmonkey-2.0.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils qmake-utils

MY_PN=${PN}2
MY_P=${PN}_v${PV}

DESCRIPTION="Powerful text searches using regular expressions"
HOMEPAGE="http://searchmonkey.sourceforge.net/"
# Switch to ^s when we switch to EAPI=6.
SRC_URI="mirror://sourceforge/project/${PN}/S${MY_PN:1}/${PV}%20%5Bstable%5D/${MY_P}.zip"

LICENSE="GPL-3"
SLOT="2"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
dev-qt/qtcore:4
dev-qt/qtgui:4"
DEPEND="${RDEPEND}
app-arch/unzip"

S="${WORKDIR}"/${MY_P}

PATCHES=(
"${FILESDIR}"/${P}-gcc4.7.patch
"${FILESDIR}"/${P}-gcc6.patch
)

src_compile() {
eqmake4
}

src_install() {
newbin ${PN} ${MY_PN}

# Hand-made desktop icon
doicon pixmaps/searchmonkey-300x300.png
domenu "${FILESDIR}"/${P}.desktop
}
7 changes: 5 additions & 2 deletions app-text/searchmonkey/searchmonkey-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=4
Expand Down Expand Up @@ -26,7 +26,10 @@ DEPEND="${RDEPEND}

S="${WORKDIR}"/${MY_P}

PATCHES=( "${FILESDIR}"/${P}-gcc4.7.patch )
PATCHES=(
"${FILESDIR}"/${P}-gcc4.7.patch
"${FILESDIR}"/${P}-gcc6.patch
)

src_install() {
newbin ${PN} ${MY_PN}
Expand Down

0 comments on commit f89080a

Please sign in to comment.