Skip to content

Commit

Permalink
net-dns/knot: bump to 2.7.6 and 2.8.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Pierre-Olivier Mercier <[email protected]>
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
nemunaire authored and mgorny committed Apr 19, 2019
1 parent 76a76e0 commit f90514d
Show file tree
Hide file tree
Showing 3 changed files with 216 additions and 0 deletions.
2 changes: 2 additions & 0 deletions net-dns/knot/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,5 @@ DIST knot-2.6.9.tar.xz 1126872 BLAKE2B c15b7e61ccad5417ce53f3d3895014931a2825835
DIST knot-2.7.2.tar.xz 1148880 BLAKE2B bf3042d762d2b66f47dbd27a1c9ecd03d111259c7db82254c1175e660497fd8343c3f1cf1cc14e6068cb3d3618931b659888a7b97d7d6e4ba9d0e74c00540e31 SHA512 e09f8a38e975ff4f90db59db9ae8a6baaca9b0cbc9c2ecd37225febfe718b7c2038ae45481ed830dc66f2b70d8312266e2dc7cb54a0aa0fdc02c87ca42bac96d
DIST knot-2.7.3.tar.xz 1146456 BLAKE2B d584db01b2354c259cf5e5cdfeb2dff677b04e76b68156a2c672fffe95ee8c6516f82b8e199d8ec8cacfcd93f15b370a25172826460b82c5964f38207c9818f2 SHA512 ba735eb06d99f8cb41619f44413f6450178ab249ef9ff282bae36e8e965cb421f082852bbf0ae5814e3e3148f27431fc1f2b4ed30e21bfd0cbea1be189bdadfd
DIST knot-2.7.4.tar.xz 1148652 BLAKE2B 081a23a0429b4fec1feebbe417bc95fe24d11404a2a6b9e4e71d89f99bc9cf2a5ed2bdc3a0fd2727cc4d45629b71faefda179e68c4781f8b21c475a7b1fe8bdd SHA512 e5f60a23817503468b18eaea517c5936945b901f568c56cb1ca67a208cc6206ff103e9ca03f1bf05018d13a688f54580ae816a5d70510f28a98ae31116a3f674
DIST knot-2.7.6.tar.xz 1151068 BLAKE2B aba7b9f89d98ddabe5596198b0767b6d88cab2278eda33bea2738bcc2f62bc3b7463ee517488f8d2efa40b11859b3aefaa212999968654e5e5580969a173ec8e SHA512 6b6a727d57337da01e2d44abec7fde4504d112604769b118fe6254b0317f149ed4e9fab321a04517eccedb08e409818d1817fc1136c27d1fd351538e6816022a
DIST knot-2.8.0.tar.xz 1168900 BLAKE2B e6d54709ce0bbc5411918de337fd2eb1cb939bbaf1b0dec149b169c2a93c6c0f4719028e35ff9a07d940d5e30470a4661e847a83c73ba0baaf89a520d8ee4fc3 SHA512 0cf2840d908bbab3197bff82d37e4a754204a3b79efa7e982719bc19028519d3ff0b2177780dada54e1b070f5f7aa28dab7bbfcc2d2ea086817f3a29b746228e
107 changes: 107 additions & 0 deletions net-dns/knot/knot-2.7.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,107 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd user

DESCRIPTION="High-performance authoritative-only DNS server"
HOMEPAGE="https://www.knot-dns.cz/"
SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

KNOT_MODULES=(
"+cookies"
"+dnsproxy"
"dnstap"
"geoip"
"+noudp"
"+onlinesign"
"+queryacl"
"+rrl"
"+stats"
"+synthrecord"
"+whoami"
)
IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"

RDEPEND="
dev-db/lmdb
dev-libs/libedit
dev-libs/userspace-rcu:=
dev-python/lmdb
net-libs/gnutls:=
caps? ( sys-libs/libcap-ng )
dnstap? (
dev-libs/fstrm
dev-libs/protobuf-c:=
)
geoip? ( dev-libs/libmaxminddb:= )
idn? (
!libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
libidn2? ( net-dns/libidn2:= )
)
systemd? ( sys-apps/systemd:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? ( dev-python/sphinx )
"

S="${WORKDIR}/${P/_/-}"

src_configure() {
local u
local my_conf=(
--with-storage="${EPREFIX}/var/lib/${PN}"
--with-rundir="${EPREFIX}/var/run/${PN}"
$(use_enable fastparser)
$(use_enable dnstap)
$(use_enable doc documentation)
$(use_enable utils utilities)
--enable-systemd=$(usex systemd)
$(use_with idn libidn)
)

for u in "${KNOT_MODULES[@]#+}"; do
my_conf+=("$(use_with ${u} module-${u})")
done

econf "${my_conf[@]}"
}

src_compile() {
default

if use doc; then
emake -C doc html
HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
fi
}

src_test() {
emake check
}

src_install() {
default

rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
keepdir /var/lib/${PN}

newinitd "${FILESDIR}/knot.init" knot
if use systemd; then
systemd_newunit "${FILESDIR}/knot-1.service" knot.service
fi

find "${D}" -name '*.la' -delete || die
}

pkg_postinst() {
enewgroup knot 53
enewuser knot 53 -1 /var/lib/knot knot
}
107 changes: 107 additions & 0 deletions net-dns/knot/knot-2.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,107 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd user

DESCRIPTION="High-performance authoritative-only DNS server"
HOMEPAGE="https://www.knot-dns.cz/"
SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

KNOT_MODULES=(
"+cookies"
"+dnsproxy"
"dnstap"
"geoip"
"+noudp"
"+onlinesign"
"+queryacl"
"+rrl"
"+stats"
"+synthrecord"
"+whoami"
)
IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"

RDEPEND="
dev-db/lmdb
dev-libs/libedit
dev-libs/userspace-rcu:=
dev-python/lmdb
net-libs/gnutls:=
caps? ( sys-libs/libcap-ng )
dnstap? (
dev-libs/fstrm
dev-libs/protobuf-c:=
)
geoip? ( dev-libs/libmaxminddb:= )
idn? (
!libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
libidn2? ( net-dns/libidn2:= )
)
systemd? ( sys-apps/systemd:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? ( dev-python/sphinx )
"

S="${WORKDIR}/${P/_/-}"

src_configure() {
local u
local my_conf=(
--with-storage="${EPREFIX}/var/lib/${PN}"
--with-rundir="${EPREFIX}/var/run/${PN}"
$(use_enable fastparser)
$(use_enable dnstap)
$(use_enable doc documentation)
$(use_enable utils utilities)
--enable-systemd=$(usex systemd)
$(use_with idn libidn)
)

for u in "${KNOT_MODULES[@]#+}"; do
my_conf+=("$(use_with ${u} module-${u})")
done

econf "${my_conf[@]}"
}

src_compile() {
default

if use doc; then
emake -C doc html
HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
fi
}

src_test() {
emake check
}

src_install() {
default

rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
keepdir /var/lib/${PN}

newinitd "${FILESDIR}/knot.init" knot
if use systemd; then
systemd_newunit "${FILESDIR}/knot-1.service" knot.service
fi

find "${D}" -name '*.la' -delete || die
}

pkg_postinst() {
enewgroup knot 53
enewuser knot 53 -1 /var/lib/knot knot
}

0 comments on commit f90514d

Please sign in to comment.