Skip to content

Commit

Permalink
dev-cpp/libxmlpp: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
pacho2 committed Dec 5, 2016
1 parent baea1e5 commit f916718
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/libxmlpp/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libxml++-2.40.1.tar.xz 955220 SHA256 4ad4abdd3258874f61c2e2a41d08e9930677976d303653cd1670d3e9f35463e9 SHA512 a4ec2e8182d981c57bdcb8f0a203a3161f8c735ceb59fd212408b7a539d1dc826adf6717bed8f4d544ab08afd9c2fc861efe518e24bbd3a1c4b158e2ca48183a WHIRLPOOL f1888bc6f90dd10dea04f617f317a2eed79f2c4981e03b1fbdb3cefcc4bfeadc256c5dd6163d82b7b33cb29d8d15de98de822d2d40f3fa8e8851efe827cdff72
DIST libxml++-3.0.0.tar.xz 934588 SHA256 2ff3640417729d357bada2e3049061642e0b078c323a8e0d37ae68df96547952 SHA512 5474006bd0e473b999f0d27e31e06d6509ce009f479d74c0114cde96858706318ba7367e0652a91b3a567c00b73e53dee4f951beb81dfb3ba42412fb21eec1de WHIRLPOOL bd6a1c905b7bae4ad15be7b3f23d0aed28262c9c5b1fff744b27fc1c01a9ff3a2f8ca66dca54ad2e607aeab688d24de57ae90c39990a3a9e29839ae79182d1c2
DIST libxml++-3.0.1.tar.xz 948796 SHA256 19dc8d21751806c015179bc0b83f978e65c878724501bfc0b6c1bcead29971a6 SHA512 9b8ccea9df11d70bb23d7d9983b18d28c648aa0107f9654a79d1cfe97db4633b69dd4b97b76d155aca8553d014a314247851f18d0371717e44a056ee804ccd95 WHIRLPOOL 289641871fecd74f46f76d731b839796130b52d16c3ad16930be850987c84e9d152e3d5d99674d2053cbab19e17a0006b93c42213e32119b29bd7a95df0349eb
37 changes: 37 additions & 0 deletions dev-cpp/libxmlpp/libxmlpp-3.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
GNOME_ORG_MODULE="${PN/pp/++}"

inherit gnome2 multilib-minimal

DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
HOMEPAGE="http://libxmlplusplus.sourceforge.net/"

LICENSE="LGPL-2.1"
SLOT="3.0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="doc"

RDEPEND="
>=dev-libs/libxml2-2.7.7[${MULTILIB_USEDEP}]
>=dev-cpp/glibmm-2.32[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
virtual/pkgconfig[${MULTILIB_USEDEP}]
"

multilib_src_prepare() {
gnome2_src_prepare
}

multilib_src_configure() {
ECONF_SOURCE="${S}" gnome2_src_configure \
$(use_enable doc documentation)
}

multilib_src_install() {
gnome2_src_install
}

0 comments on commit f916718

Please sign in to comment.