Skip to content

Commit

Permalink
app-text/zathura: Sync live ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <[email protected]>
  • Loading branch information
Zlogene committed Sep 13, 2019
1 parent 29c4e71 commit f9326b0
Showing 1 changed file with 19 additions and 24 deletions.
43 changes: 19 additions & 24 deletions app-text/zathura/zathura-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit gnome2-utils meson virtualx xdg-utils
inherit meson virtualx

DESCRIPTION="A highly customizable and functional document viewer"
HOMEPAGE="http://pwmt.org/projects/zathura/"
Expand All @@ -13,50 +13,45 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
EGIT_BRANCH="develop"
else
SRC_URI="https://pwmt.org/projects/zathura/download/${P}.tar.xz"
SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
fi

LICENSE="ZLIB"
SLOT="0"
IUSE="+magic seccomp sqlite synctex test"
IUSE="doc +magic seccomp sqlite synctex test"

RDEPEND=">=dev-libs/girara-0.3.1
RESTRICT="!test? ( test )"

DEPEND=">=dev-libs/girara-0.3.3
>=dev-libs/glib-2.50:2
dev-python/sphinx
>=sys-devel/gettext-0.19.8
x11-libs/cairo
x11-libs/cairo[X]
>=x11-libs/gtk+-3.22:3
magic? ( sys-apps/file )
seccomp? ( sys-libs/libseccomp )
sqlite? ( >=dev-db/sqlite-3.5.9:3 )
synctex? ( app-text/texlive-core )"

DEPEND="${RDEPEND}
test? ( dev-libs/check )"
RDEPEND="${DEPEND}"

BDEPEND="virtual/pkgconfig"
BDEPEND="doc? ( dev-python/sphinx )
test? ( dev-libs/appstream-glib
dev-libs/check )
virtual/pkgconfig"

src_configure() {
local emesonargs=(
-Denable-magic=$(usex magic true false)
-Denable-seccomp=$(usex seccomp true false)
-Denable-sqlite=$(usex sqlite true false)
-Denable-synctex=$(usex synctex true false)
-Dconvert-icon=disabled
-Dmagic=$(usex magic enabled disabled)
-Dmanpages=$(usex doc enabled disabled)
-Dseccomp=$(usex seccomp enabled disabled)
-Dsqlite=$(usex sqlite enabled disabled)
-Dsynctex=$(usex synctex enabled disabled)
)
meson_src_configure
}

src_test() {
virtx meson_src_test
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_desktop_database_update
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
}

0 comments on commit f9326b0

Please sign in to comment.