Skip to content

Commit

Permalink
app-shells/psh: Add compatibility patch for Perl 5.22; other QA cleanups
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
akhuettel committed Dec 3, 2015
1 parent 3db5c05 commit f939882
Show file tree
Hide file tree
Showing 3 changed files with 53 additions and 3 deletions.
11 changes: 11 additions & 0 deletions app-shells/psh/files/psh-1.8.1-defined-array.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- lib/Psh.pm 2007-07-21 16:40:44.000000000 +1200
+++ lib/Psh.pm 2015-07-18 05:30:29.840928282 +1200
@@ -367,7 +367,7 @@

sub defined_and_nonempty
{
- if (!defined(@_)) { return 0; }
+ if (!@_) { return 0; }
if (scalar(@_) == 0) { return 0; }

if (scalar(@_) == 1) {
7 changes: 4 additions & 3 deletions app-shells/psh/psh-1.8.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2013 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -16,8 +16,9 @@ KEYWORDS="amd64 ppc x86"
# Package warrants USE doc & examples
IUSE="readline"

DEPEND=""
RDEPEND="readline? (
DEPEND="<dev-lang/perl-5.22.0"
RDEPEND="<dev-lang/perl-5.22.0
readline? (
dev-perl/Term-ReadLine-Gnu
dev-perl/TermReadKey )"

Expand Down
38 changes: 38 additions & 0 deletions app-shells/psh/psh-1.8.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit perl-module

DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
HOMEPAGE="http://www.focusresearch.com/gregor/sw/psh/"
SRC_URI="http://www.focusresearch.com/gregor/download/${P}.tar.gz"

SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
# Package warrants USE doc & examples
IUSE="readline"

RDEPEND="
readline? (
dev-perl/Term-ReadLine-Gnu
dev-perl/TermReadKey
)
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
"

SRC_TEST="do parallel"
myinst="SITEPREFIX=${D}/usr"

PATCHES=(
"${FILESDIR}/${P}-defined-array.patch"
)

src_install() {
perl-module_src_install
dodoc examples/complete-examples doc/*
}

0 comments on commit f939882

Please sign in to comment.