Skip to content

Commit

Permalink
media-gfx/openscad: Version bump (big thanks to Jesper Saxtorph, bug …
Browse files Browse the repository at this point in the history
…635062).

Package-Manager: Portage-2.3.16, Repoman-2.3.6
  • Loading branch information
xmw committed Dec 9, 2017
1 parent d55c7cd commit f94195e
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/openscad/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST openscad-2015.03-2.src.tar.gz 13307974 SHA256 a2535bb9e27d96e10e1e19268a596155164c7129d410a0c7f96edc2d09400083 SHA512 66e93715987a5211ce15c10ea39a9fec3296b606ace0aba1cda019635d5b26021457c8e49f389daa90a0da02e41007eab662e1ed6608cb51c24de00253b9783f WHIRLPOOL 1454a22464f5dcf9726d5bb4fa5f7c080e419e44a3877a5ac43590e2b0552ecb169a9d2a9e15868c8020ffcfb894fc84f0269460f032f516ec9286f27155ca73
DIST openscad-2015.03-3.src.tar.gz 13309147 BLAKE2B 77f4e934474882e454dad683d9da6a2c9fe699a84c86ed5ebe1755de037f6930870ffb432dedeef3bea7a76cbc98d0f0d0694e5d0f7b469830370ca3548a650c SHA512 b2cee90563bdf2cb9f7b5a0d637b2266f5fcd62add6147c9326b843a5b0975b8ec900d13a2aa86485fce4a5e7e53a08cf4171a3d1d66355e813d01ca9096faee
83 changes: 83 additions & 0 deletions media-gfx/openscad/openscad-2015.03_p3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit elisp-common qmake-utils xdg-utils

MY_PV="2015.03-3"
SITEFILE="50${PN}-gentoo.el"

DESCRIPTION="The Programmers Solid 3D CAD Modeller"
HOMEPAGE="http://www.openscad.org/"
SRC_URI="http://files.openscad.org/${PN}-${MY_PV}.src.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="emacs"

DEPEND="
dev-cpp/eigen:3
dev-libs/boost:=
dev-libs/glib:2
dev-libs/gmp:0=
dev-libs/mpfr:0=
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtopengl:5
>=media-libs/glew-2.0.0:0
media-gfx/opencsg
media-libs/fontconfig:1.0
media-libs/freetype:2
media-libs/harfbuzz
sci-mathematics/cgal:=
>=x11-libs/qscintilla-2.9.4:=[qt5(+)]
emacs? ( virtual/emacs )
"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${PN}-2015.03_p2_uic_tr_fix.patch" )

S="${WORKDIR}/${PN}-${MY_PV}"

src_prepare() {
default

#Use our CFLAGS (specifically don't force x86)
sed -i "s/QMAKE_CXXFLAGS_RELEASE = .*//g" ${PN}.pro || die
sed -i "s/\/usr\/local/\/usr/g" ${PN}.pro || die
}

src_configure() {
eqmake5 "${PN}.pro"
}

src_compile() {
default

if use emacs ; then
elisp-compile contrib/*.el
fi
}

src_install() {
emake install INSTALL_ROOT="${D}"

if use emacs; then
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
elisp-install ${PN} contrib/*.el contrib/*.elc
fi

einstalldocs
}

pkg_postinst() {
xdg_mimeinfo_database_update
xdg_desktop_database_update
}

pkg_postrm() {
xdg_mimeinfo_database_update
xdg_desktop_database_update
}

0 comments on commit f94195e

Please sign in to comment.