Skip to content

Commit

Permalink
dev-tcltk/bwidget: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 19, 2015
1 parent 521f50a commit f96eead
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-tcltk/bwidget/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST bwidget-1.9.8.tar.gz 252668 SHA256 545016e3ee998991308f54d8ef26bbf16144ee50fa432b9100d37ef806bdb314 SHA512 437958871809c8ce285cbf4521ff08720d106dca708183ff94234015da2b04ccb3a7b05df13d8e3f46466106c91418607c5983fc4ed8d9c4285ae0a0b1071262 WHIRLPOOL 4ee88816e8abab426c846ccc8a688a347ba9bdc43288b10ec56fec3f695f7733140441a686f321035cb1aebfc100178c263945c8a36c4b15b1ad227af72ee844
DIST bwidget-1.9.9.tar.gz 243001 SHA256 b0e943b31b3513e9cc9a49e3f71d8b895ab55f5c8dfeaf849c8c308697f13573 SHA512 6374c9127ab37dd2cc3ede30fc525a7d0f226a995e44f7b1c9751e1c5520090bfbbae5cfcb5cbeec4d1c89eb8f4cd7eb2e453ac055d4ae5ef4b7b77512d2e042 WHIRLPOOL 8801d61696deaed01ab10f18aa421db9e4d2db95b150be222c40fd57174526c472644ac8cdc089c05975becade45cfc53633609611b36510004f4813341e59cb
43 changes: 43 additions & 0 deletions dev-tcltk/bwidget/bwidget-1.9.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils multilib virtualx

MY_PN=${PN/bw/BW}
MY_P=${MY_PN}-${PV}

DESCRIPTION="High-level widget set for Tcl/Tk"
HOMEPAGE="http://tcllib.sourceforge.net/"
SRC_URI="mirror://sourceforge/project/tcllib/${MY_PN}/${PV}/${P}.tar.gz"

LICENSE="tcltk"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"

DEPEND="dev-lang/tk:0"
RDEPEND="${DEPEND}"

src_prepare() {
epatch "${FILESDIR}"/${PN}-1.9.8-test.patch
}

src_test() {
VIRTUALX_COMMAND=tclsh
virtualmake tests/entry.test
}

src_install() {
insinto /usr/$(get_libdir)/${P}
doins *.tcl
doins -r images lang

insinto /usr/share/doc/${PF}/
doins -r demo
dodoc ChangeLog README.txt

use doc && dohtml BWman/*
}

0 comments on commit f96eead

Please sign in to comment.