forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/docker-registry: Version bump to 2.6.2
Gentoo-Bug: 626038 Package-Manager: Portage-2.3.6, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
43 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST docker-registry-2.5.1.tar.gz 1604279 SHA256 d98ebca3518c17d95468b1d40b87861036001301a16a50563203e4b9af72c514 SHA512 5217e2ca361d71806c8ec4da1cf1c2c5dc4160b84c2a98feae50872342d0acf116768a3acf00769bafd66e73c9922c7fe97cbde51955d8aa1d1ed914de2e3d34 WHIRLPOOL 12db4c397f6309a57252cfe19a055f610567c526a05220c9b6ac0d7ff21863520cc126f95b34c8e48fb7ae6ba6a298d0e6b53bf4866cf13bf95fcfb591c538b7 | ||
DIST docker-registry-2.6.0.tar.gz 1578641 SHA256 5e03dbeaf87936b06d3c6f61fb12d9f759b2ca89225eb71b288488a2fd10571c SHA512 589ef6968d4f71a8e0c201c02007fb6cf80a9206e0ba699be6cc6cc29a5bfeb759bc8928a21fb73a3710d747eb99136c228b630889af8870cdfa508e20ff5f4e WHIRLPOOL 71c4c78ee587f5346127eed4cb00d3bb55c565e5d376c0a4c7f7b3ec7c7fbc10377e190bf98833a6ac6e8e43f3a100526554b5f5e24238a1de047fc458edf74d | ||
DIST docker-registry-2.6.1.tar.gz 1577794 SHA256 21d1b5fd4001c45d125d6345c387f1840f984c069b5556d0c8ad1850d6e25b9f SHA512 a2175cb5ab049599e1bdae7026dc84e14b79883eca3ceaafda54497a1743103f125f65fa3922c003363dd86aa1422f539aff8b17746b9768968fef757e931c36 WHIRLPOOL 3e1c5684462d6e31d3f28d67f4ab2dacf8037b793c11ecca49846ca4124a0ce54b9481471cb77190dc3b63de882571b88beba1bb5d7d04b8cbb92b8a597b0fed | ||
DIST docker-registry-2.6.2.tar.gz 1579760 SHA256 963e4e98a99f484c903b888e2661a10794e79906ccf9a6a9b17172f9c1705f0d SHA512 a091db2e15d7c1dc8cd39a40de5bb63cc1ead68e95dfaf6b3735a789adb87f146c03eff81f700e0059e5f6ffc43e6c3dd3358503697882cb080b991629f82c60 WHIRLPOOL 55f9e7cc5a643be1d791e6d19610db9a8a4c59f7c73ae105cce11917b12691418fa2d310103788d06d74c6bfc809d20de9f5e1a1ab4b3861062db93c8861158f |
42 changes: 42 additions & 0 deletions
42
app-emulation/docker-registry/docker-registry-2.6.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit golang-vcs-snapshot systemd user | ||
|
||
KEYWORDS="~amd64" | ||
EGO_PN="github.com/docker/distribution" | ||
EGIT_COMMIT="v${PV}" | ||
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz" | ||
DESCRIPTION="Docker Registry 2.0" | ||
HOMEPAGE="https://github.com/docker/distribution" | ||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="" | ||
SVCNAME=registry | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-2.6.1-notifications-expvar.patch" ) | ||
|
||
pkg_setup() { | ||
enewgroup ${SVCNAME} | ||
enewuser ${SVCNAME} -1 -1 /dev/null ${SVCNAME} | ||
} | ||
|
||
src_compile() { | ||
GOPATH="${S}" \ | ||
go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}/..." || die | ||
} | ||
|
||
src_install() { | ||
exeinto /usr/libexec/${PN} | ||
doexe bin/* | ||
insinto /etc/docker/registry | ||
newins src/${EGO_PN}/cmd/registry/config-example.yml config.yml.example | ||
newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}" | ||
newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}" | ||
systemd_dounit "${FILESDIR}/${SVCNAME}.service" | ||
keepdir /var/{lib,log}/${SVCNAME} | ||
fowners ${SVCNAME}:${SVCNAME} /var/{lib,log}/${SVCNAME} | ||
insinto /etc/logrotate.d | ||
newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}" | ||
} |