Skip to content

Commit

Permalink
dev-ruby/i18n: add 0.8.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
graaff committed Feb 1, 2017
1 parent 16bc05e commit f986b56
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/i18n/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST i18n-0.6.11.gem 61440 SHA256 b37dda25b30484f2674a851e24ae098a38564a61c976fa91a34bf8fceaa3923b SHA512 f3c26c13b333daed69dc044985816d79a27a489c860caaa03cd64b3ff31e3ea65aa850dd581162a264d0b0bb6bc383b12cb96c1a97d5d1d04bee45517a48b721 WHIRLPOOL 67b702b94e3d56331845d8088bce37b7e34ed1a0a035e32ee986054850f205680703f472f3a5f494cda7608bd2db15426e3dcb672f0e8863c5b3b31292f9057c
DIST i18n-0.6.9.gem 60416 SHA256 1cd368e0b3854e8067955643892b18040e1d17f3c768daef8901298222e88e5d SHA512 8bb28578bfe121f293058a6ca99ba8e87195b2735f084190e5096655b7eee5ed44751bb56dde823e5ee8094668e93958af4999642308c5b7189d95dd892a3b63 WHIRLPOOL ee09dfbeaecccafb4e91f7adac479a8a6b01b0fa636b622f4440938e559d801153c5d2016c02b61581c3f70b3747bdee01db0c5acc4a03339724916d20cdd3b3
DIST i18n-0.7.0.tar.gz 57647 SHA256 8a9ea123661e5da978ecffadc8d1b7ea50ba2d8e9de1455d61e7848cc6c2c855 SHA512 8824feb3fb99bba759963d2ae34555f27b85dbac3d3001168471a27e47fc805e5ffe5c3b4e10d6ca4b2e2524ec16c98260b981ef504f274aab93f912a57d2e14 WHIRLPOOL 0f16ab5f06ae7ec75eefbec985d183dac5a2cd572d6c70fc3de8616bec8834e210a5660a74657ae3397017962253350e6bd926c0d2c9509400ceadc5b365fa9d
DIST i18n-0.8.0.tar.gz 59973 SHA256 18da8d5e28e7143b128d78e270d96e7e5c7baaec151f69ad08d37d6b4b024468 SHA512 f75ab19e913877938740c0ff772c95becb59aac6a2c1adc01d18e41225e7834fba4c891b81eee052f8d991703afb470b032faf5429e70b073dd48c2cbe826a11 WHIRLPOOL 9d825a679a5243e2e62efc01a62e93e9284903240c4fe364ed20b8f2ef43d800817ddd0e60c9ed1d41126fec768e5d9969f74efc9ce2feb6a10543fd4608ef37
54 changes: 54 additions & 0 deletions dev-ruby/i18n/i18n-0.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby21 ruby22 ruby23"

RUBY_FAKEGEM_RECIPE_TEST="test"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem versionator

DESCRIPTION="Add Internationalization support to your Ruby application"
HOMEPAGE="http://rails-i18n.org/"
SRC_URI="https://github.com/svenfuchs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

ruby_add_bdepend "test? (
>=dev-ruby/activesupport-3.2 <dev-ruby/activesupport-4.3
dev-ruby/bundler
>=dev-ruby/mocha-0.13
dev-ruby/test_declarative )"

all_ruby_prepare() {
# Remove bundler lock files since we cannot depend on specific
# versions in Gentoo.
rm gemfiles/*.lock || die
}

each_ruby_test() {
case ${RUBY} in
*ruby22|*ruby23)
versions="4.2 5.0"
;;
*)
versions="4.1 4.2"
;;
esac

for version in ${versions} ; do
if has_version "dev-ruby/activesupport:${version}" ; then
einfo "Running tests with activesupport ${version}"
BUNDLE_GEMFILE="${S}/gemfiles/Gemfile.rails-${version}.x" ${RUBY} -S bundle exec ${RUBY} -S rake test || die
fi
done
}

0 comments on commit f986b56

Please sign in to comment.