forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/msgpack: version bump to 1.0.0
Closes: https://bugs.gentoo.org/710270 Signed-off-by: Jeffrey Lin <[email protected]> Closes: gentoo#14718 Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
6972f43
commit f99895c
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST msgpack-0.6.2.tar.gz 119062 BLAKE2B 6b20a0d31b811ae66e66dbfaacec6f0cf2152b2937423b78f3e6244bfa49c87767788c5ee1db41b9020801b8777a4c15b1fe1853182718adf622bc7e1bff858e SHA512 95b92e3d35e0500dd4256d18bf76e586e57cc66319b4459ac5daef599277a5049177a89ad86e291dbdc4c7a918901a89d9218353ddc4a7d0b399e8a98afef363 | ||
DIST msgpack-1.0.0.tar.gz 232331 BLAKE2B ab7b3aede06c31e0cf70a7f7fbdf2b1dddd89aa2d5d9847b11117c66a2f4572ac468674cdbcaf79bc571278f02429d223aeeb0ea8cb50c31ad251142642cc05f SHA512 6dc168b111cd37807e8e8a09840d1b116d7f38d56f4622b9d36ab7dbd983ebe2f34e763f48c6348148c6945c9f1c9a0f83f5f03e12d12bc18f7b8e0cbd669f87 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python3_{6,7,8} pypy3 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="MessagePack (de)serializer for Python" | ||
HOMEPAGE="https://msgpack.org | ||
https://github.com/msgpack/msgpack-python/ | ||
https://pypi.org/project/msgpack/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86" | ||
IUSE="+native-extensions test" | ||
|
||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
native-extensions? ( | ||
$(python_gen_cond_dep '>=dev-python/cython-0.16[${PYTHON_USEDEP}]' 'python*') | ||
) | ||
test? ( dev-python/six[${PYTHON_USEDEP}] ) | ||
" | ||
|
||
distutils_enable_tests pytest | ||
|
||
python_prepare_all() { | ||
# Remove pre-generated cython files | ||
rm msgpack/{_packer,_unpacker,_cmsgpack}.pyx || die | ||
|
||
if ! use native-extensions ; then | ||
sed -i -e "/have_cython/s:True:False:" setup.py || die | ||
fi | ||
distutils-r1_python_prepare_all | ||
} |