Skip to content

Commit

Permalink
app-emulation/docker-swarm: version bump to 1.0.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
zmedico committed Dec 27, 2015
1 parent 7b86453 commit f9a4feb
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/docker-swarm/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST docker-swarm-0.4.0.tar.gz 853254 SHA256 c3ee1a34ce86da4d31f652c871dfa120fc78d5cc835e391034d740e83b48f7a3 SHA512 ffaa5560d67cafcc97b091d87b7792d6a0bfed2fb08837854a8313175742d535ee671fe45c4b96eeb69bf613a31e2e37cf92524f93ad20fbfbd54647b956c9c1 WHIRLPOOL 3acb07bfbcf33d70dffbfff4c5028767f36d51bd3500143d50e109d062cfd0107dfdc9f45724d08f874d81e15429089ed18a664fd591c26d7f2ff14ea933f93a
DIST docker-swarm-1.0.1.tar.gz 1187966 SHA256 33c6566af395affbf9861d1491613c48a70e6c61c532910cef2210be7b1323f7 SHA512 ed5e6a37cd0f5a816367cab451d21ac20183f8ce767a30dc3086f849da8e0d2662c9f9b7e56d826e7e8cf5d4ec3d9f1ee8c159cca294af7ec45c2c1a21eaaf80 WHIRLPOOL e17705a3bef077e5fed552131aa7cd4891934a537dc93bbb8dfe81bf2e82c281d7f74a5150febdde26f492cf5ad4eec8417aac9a7edc6e48812f4af3ed1b624e
37 changes: 37 additions & 0 deletions app-emulation/docker-swarm/docker-swarm-1.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

EGO_PN=github.com/docker/${PN##*-}/...

if [[ ${PV} = *9999* ]]; then
inherit golang-vcs
else
KEYWORDS="~amd64"
EGIT_COMMIT="v${PV}"
SRC_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
inherit golang-vcs-snapshot
fi
inherit golang-build

DESCRIPTION="A Docker-native clustering system"
HOMEPAGE="https://docs.docker.com/${PN##*-}/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
RESTRICT="test"
DEPEND=""
RDEPEND=""
S=${WORKDIR}/${P}/src/${EGO_PN%/*}

src_compile() {
GOPATH="${WORKDIR}/${P}:${S}/Godeps/_workspace:$(get_golibdir_gopath)" \
go build -v -work -x ${EGO_BUILD_FLAGS} -o ${PN} || die
}

src_install() {
dobin ${PN}
dodoc CHANGELOG.md CONTRIBUTING.md README.md ROADMAP.md
}

0 comments on commit f9a4feb

Please sign in to comment.