Skip to content

Commit

Permalink
lxqt-base/lxqt-runner: add version 2.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Jimi Huotari <[email protected]>
  • Loading branch information
Chiitoo committed Jun 14, 2024
1 parent 224afbb commit f9b8cbb
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions lxqt-base/lxqt-runner/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST lxqt-runner-1.3.0.tar.xz 223880 BLAKE2B 2ba95d7d24bbdf656ed364c449513c65d340bc55b283ef1914244151068d99b3f67d76622286f246eeeddd4bdd09cf59fdd3ea127ce11c244a92189b16ae9203 SHA512 79351e4cebb14ce6578197dc4d4ec3ee3b5be3d3832da778b075c5e2da38dcb518113c8076a4488570e68f51cedc5a3fe4855e296e813aa2b848a386ddcd6fbc
DIST lxqt-runner-1.4.0.tar.xz 224920 BLAKE2B 50b1bf16ce41fa263392c8c2d304658c1636bd7022bad4774b71fb4911fafa9cf9ce4dd32b1146533c7f0b13c9ddb716204910ecb0c3ecf95dfb8e9df9bef4c7 SHA512 53ead3b6cd45cbf57a01c06861a97f20ddab9f3a5f3a90b3b9c3e6c3b67344feec99e11e14a90a0d0a6beb7e0cf74e092b5664d5f8ec32f827893623e104ee12
DIST lxqt-runner-2.0.0.tar.xz 226344 BLAKE2B 3b831d1d1b0226e1785d4ee4fc93055cf01426335001c432cfc099f75c14421f467fa761648e77d826dfd6b36c9867779b88e38d971fe78846b102bcb7c945d1 SHA512 4c9ff79a0a4b7167023bd5447c83692be2e4e79ae48b6069deadae8ab4e5d6d73e6439169ffce87fc8f6000e65ed354fffb58188e9ba4f762b177b1c85c284c5
43 changes: 43 additions & 0 deletions lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="LXQt quick launcher"
HOMEPAGE="https://lxqt-project.org/"

MY_PV="$(ver_cut 1-2)"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64"
fi

LICENSE="LGPL-2.1 LGPL-2.1+"
SLOT="0"

BDEPEND="
>=dev-qt/qttools-6.6:6[linguist]
>=dev-util/lxqt-build-tools-2.0.0
virtual/pkgconfig
"
DEPEND="
>=dev-cpp/muParser-2.2.3
>=dev-libs/libqtxdg-4.0.0
>=dev-qt/qtbase-6.6:6[dbus,gui,widgets,xml]
kde-frameworks/kwindowsystem:6
>=kde-plasma/layer-shell-qt-6.0:6
=lxqt-base/liblxqt-${MY_PV}*:=
=lxqt-base/lxqt-globalkeys-${MY_PV}*
"
RDEPEND="${DEPEND}"

src_install() {
cmake_src_install
doman man/*.1
}

0 comments on commit f9b8cbb

Please sign in to comment.