forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/vault: Version bump to 0.11.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
- Loading branch information
Showing
2 changed files
with
68 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST vault-0.10.3.tar.gz 15902247 BLAKE2B f69ddbe1309800cfae756f8ca1dd0da3e92ce49a1ec70539dc30785344afb7fe39472dcb2fb5ee4f410c7b52b13b00996b08d89624ef8523adcf4f809601ad5c SHA512 baacf549f9b73d306154dad6cd6efb3fb0eca3280c885cd772dada524cd436c1d5f1f705118274aa7cea6002cd8e0b86f1dfb02c4f5787d08dc535112cb62096 | ||
DIST vault-0.10.4.tar.gz 19207588 BLAKE2B 035e83c1d119b266817490afd4506fee5e5ceeff8a7c59188c59e28067f06e78f57e06d200026b288908f49a19ed22ebfd67e08c3c70026c7da22d05e33ec343 SHA512 7331e49c2bebbbbcebc74cfc1ce7d6984590fdd39b47f0bbf1b610cfe37b900a86b8ea63bc5d5e28ba34b68433944486979177aee6c10bf188095f5a50a4b61a | ||
DIST vault-0.11.0.tar.gz 24430984 BLAKE2B 0c1d40ed9f8dbc19ae7bce38308f7a55e12e8a907798022ce6b5783f2be9b9d7a9a1842683b8df411b3b754c716fd7366a0261d890e2153c64a70df6a3c6b844 SHA512 33e1e76a0e16803a8d0d6ed8ec0b6d1f8876d54ecf35a70bc4969404bd7991ef0cc5986eae958885d288bb316396e0594a5571b7a11f8b052b22b445388f03c7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit fcaps golang-base golang-vcs-snapshot systemd user | ||
|
||
EGO_PN="github.com/hashicorp/${PN}" | ||
DESCRIPTION="A tool for managing secrets" | ||
HOMEPAGE="https://vaultproject.io/" | ||
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
SLOT="0" | ||
LICENSE="MPL-2.0" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
RESTRICT="test" | ||
|
||
DEPEND=">=dev-lang/go-1.10:= | ||
dev-go/gox" | ||
|
||
FILECAPS=( | ||
-m 755 'cap_ipc_lock=+ep' usr/bin/${PN} | ||
) | ||
|
||
src_prepare() { | ||
default | ||
# Avoid the need to have a git checkout | ||
sed -e 's:^\(GIT_COMMIT=\).*:\1:' \ | ||
-e 's:^\(GIT_DIRTY=\).*:\1:' \ | ||
-e s:\'\${GIT_COMMIT}\${GIT_DIRTY}\':: \ | ||
-i src/${EGO_PN}/scripts/build.sh || die | ||
sed -e "/hooks/d" -i src/${EGO_PN}/Makefile || die | ||
} | ||
|
||
pkg_setup() { | ||
enewgroup ${PN} | ||
enewuser ${PN} -1 -1 -1 ${PN} | ||
} | ||
|
||
src_compile() { | ||
mkdir bin || die | ||
export GOPATH=${S} | ||
cd src/${EGO_PN} || die | ||
XC_ARCH=$(go env GOARCH) \ | ||
XC_OS=$(go env GOOS) \ | ||
XC_OSARCH=$(go env GOOS)/$(go env GOARCH) \ | ||
emake | ||
} | ||
|
||
src_install() { | ||
dodoc src/${EGO_PN}/{CHANGELOG.md,CONTRIBUTING.md,README.md} | ||
newinitd "${FILESDIR}/${PN}.initd" "${PN}" | ||
newconfd "${FILESDIR}/${PN}.confd" "${PN}" | ||
insinto /etc/logrotate.d | ||
newins "${FILESDIR}/${PN}.logrotated" "${PN}" | ||
systemd_dounit "${FILESDIR}/${PN}.service" | ||
|
||
keepdir /etc/${PN}.d | ||
insinto /etc/${PN}.d | ||
doins "${FILESDIR}/"*.json.example | ||
|
||
keepdir /var/log/${PN} | ||
fowners ${PN}:${PN} /var/log/${PN} | ||
|
||
dobin bin/${PN} | ||
} |