forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-metrics/process-exporter: mine /proc to report process stats for …
…prometheus Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: William Hubbs <[email protected]>
- Loading branch information
1 parent
b804011
commit f9d7aa4
Showing
4 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST process-exporter-0.4.0.tar.gz 378006 BLAKE2B 053379e8e0cb95f099cebf53289c48c39d6c8ef22c8b0dcf0bd128453e601da98be9205bb5c7cda8a05d5f50addabbcb46f6ece44926da17c1bd8616e452783a SHA512 88f6f0e07bb7f3ea6c593ba359c09ace47eb0830ff0759b1f4dd64219a6c9069dc2891a328a90bdef13ea02efc576fb71de7ff095788b4dd45c2683c90904363 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
#!/sbin/openrc-run | ||
|
||
description="Process Exporter for Prometheus" | ||
command=/usr/bin/process-exporter | ||
command_args="--config.path /etc/process-exporter/all.yaml | ||
--web.listen-address=:9256 ${COMMAND_ARGS}" | ||
command_background=yes | ||
pidfile=/var/run/process-exporter.pid |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>William Hubbs</name> | ||
</maintainer> | ||
</pkgmetadata> |
32 changes: 32 additions & 0 deletions
32
app-metrics/process-exporter/process-exporter-0.4.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
EGO_PN=github.com/ncabatoff/process-exporter | ||
|
||
inherit golang-build golang-vcs-snapshot systemd | ||
|
||
DESCRIPTION="Process exporter for prometheus" | ||
HOMEPAGE="https://github.com/ncabatoff/process-exporter" | ||
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
RESTRICT="strip" | ||
|
||
src_compile() { | ||
pushd "src/${EGO_PN}" || die | ||
GOPATH="${S}" emake build | ||
} | ||
|
||
src_install() { | ||
pushd "src/${EGO_PN}" || die | ||
dobin ${PN} | ||
dodoc *.md | ||
insinto /etc/${PN} | ||
doins packaging/conf/all.yaml | ||
systemd_dounit packaging/${PN}.service | ||
newinitd "${FILESDIR}"/${PN}.initd ${PN} | ||
} |