Skip to content

Commit

Permalink
dev-php/pecl-mongodb: version bump to 1.2.11.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Closes: gentoo#5892
  • Loading branch information
hydrapolic authored and monsieurp committed Oct 21, 2017
1 parent 8a1998c commit f9ec26c
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-mongodb/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mongodb-1.1.10.tgz 661847 SHA256 1c779c50b5ebe25acf399d899d8df727d794588ee1ef3d2039ee0bbd7f287f18 SHA512 36096ceaec04aa4670b7d7d8e0b23edf786bab7184718642869455f5ddc6562eeb1a56f524550bea7f0dfe3aa44b12a25c32b20744ee8c843aacb1f03458ebd0 WHIRLPOOL 83670e7ec2928964deb4889f0edbb344e6594fb29133b4e56375fa26933d00227ee5a7a53ebda779e3dca9cc4ae6bc25bd6cc47cc192eeca473c4a87a32618cd
DIST mongodb-1.1.8.tgz 806900 SHA256 b93ae7dc9bd270823965f8903c9acf47fe3a0ba7a630d08e8173ff091d593ae0 SHA512 1026b4081cd1c35f1f6fee6332c21dbe739320236377c0ed21b8d64447a9ba26464a919ceb9c16b332a64f12b834700472d6cbfb336d09d841c97ca0b402bf17 WHIRLPOOL 9cd2ce71f06684a3717e1cc016684d54b877f31166cbd194dc595dc878ebdda0320210ed090ac85d2aef40c94299499feedcf52faa712cec1c14aef1ae1f25d5
DIST mongodb-1.2.11.tgz 786669 SHA256 bac347be2277dd64b1b6f414234a6057eccf2d208409ce60973107a41267df49 SHA512 19642bc156064e14c598b09a328b57c2f7c35c59268912edb88bbd1a144e5f2ea5a74860c3b9fb8552e45114cf712d7acf6f686486db328b34f0583aac8766f5 WHIRLPOOL 3c4f5db3d99d34ae30061bcdee9741062f2da0805c291ab13428a87c3ebe9a2539886bf6bf4065ce6df32709d16f359f58190e03d0b2f4ef06f6396ee7bd3b89
DIST mongodb-1.2.9.tgz 786049 SHA256 dac7f755001e454f41bd1ebf54a47754c524062d41244a75ea7ee3a9825a9d2b SHA512 7eff5cfce08f3d69bc7acdb9ab5f8f55d02dab67593e5d03402c8bb6b6611fd703e8dfda89b99e8d3de387ed58cb9eea096fe68e0c9657ec3f8b1b7f622cfe58 WHIRLPOOL a7711addba3b029d6008485a7491f7312bd0bd0faed223a647210c4c8fd559083ff8a492f126512326d27e14d5e2d54cb09998f8e5ba3feb424dc05aed91608b
40 changes: 40 additions & 0 deletions dev-php/pecl-mongodb/pecl-mongodb-1.2.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PHP_EXT_NAME="mongodb"
USE_PHP="php5-6 php7-0 php7-1"
DOCS=( README.md )

inherit php-ext-pecl-r3

DESCRIPTION="MongoDB database driver for PHP"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="libressl sasl"

RDEPEND="
php_targets_php5-6? ( dev-lang/php:5.6[json,ssl,zlib] )
php_targets_php7-0? ( dev-lang/php:7.0[json,ssl,zlib] )
php_targets_php7-1? ( dev-lang/php:7.1[json,ssl,zlib] )
>=dev-libs/libbson-1.6.0
>=dev-libs/mongo-c-driver-1.6.0[sasl?,ssl]
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
sasl? ( dev-libs/cyrus-sasl )
"
# pkgconfig needed if system libraries are used for bson and libmongoc
DEPEND="${RDEPEND} virtual/pkgconfig"

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-mongodb
--with-libbson
--with-libmongoc
--with-mongodb-sasl=$(usex sasl)
)
php-ext-source-r3_src_configure
}

0 comments on commit f9ec26c

Please sign in to comment.