Skip to content

Commit

Permalink
dev-libs/libsodium: Version bump to 1.0.11
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
mrueg committed Aug 6, 2016
1 parent 59b3e99 commit f9fe722
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libsodium/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libsodium-1.0.10.tar.gz 1827211 SHA256 71b786a96dd03693672b0ca3eb77f4fb08430df307051c0d45df5353d22bc4be SHA512 ff52e7f25787cc858e8d26be10913c689bd3dd394c8e163133920141be67a292a1dba066a1037e83cf0ced155a1554f07f24c2f33a7a6aa52521d39f537cd515 WHIRLPOOL 452ac241c26284e433c4a4595b45a1470da0be15a78761dd825460d676e48a3f36eb37ddf2c1843e3fdc64cc7cddf70dbc1aa1a983a249e1440521dc58cacf8a
DIST libsodium-1.0.11.tar.gz 1846782 SHA256 a14549db3c49f6ae2170cbbf4664bd48ace50681045e8dbea7c8d9fb96f9c765 SHA512 4b1293c4d0e52264beecdd05833857bc4d77d1c2a97eea0138fe04df383b9a2dfcad4a79ccd9aed8f6c0047ba67c49292b0d2ccf987ab0b5046b46b1586ccbd7 WHIRLPOOL ff02835e05a491695ba1b6d55d1b3168c15c9c6326377d2a24d1dbc9eaa3da538efcf22610c81d32297b057138162132e340b64ce980a199563d4101beb9d899
DIST libsodium-1.0.2.tar.gz 1673394 SHA256 961d8f10047f545ae658bcc73b8ab0bf2c312ac945968dd579d87c768e5baa19 SHA512 15fc47516f0e35906c1c304205fa991e74a273e4e6fc2186b6c16f0e41523de24493e149262b97ef03e4adc221232372ef1f283c4c23f96e4c5d99023d361e14 WHIRLPOOL 18509d9911c1d0ec6e8b9a8735abfeb2c1623669d31045abc6d9dd1289571fbe3a055f960f42a86779e7c03967532d71d7b9d0597ecfe457672e69b27b577e48
DIST libsodium-1.0.8.tar.gz 1794750 SHA256 c0f191d2527852641e0a996b7b106d2e04cbc76ea50731b2d0babd3409301926 SHA512 8f85e85e699c2b45674befd466e018c9f2ff1333c8fa806da49d9674068c33929bd3463e8908ffcd9c6154d430737e08e0522ac8ed4219e4fffe2e0a7a611c65 WHIRLPOOL 379addb00b366d2de887749fa72b17c003fa583728788e416e363a64196ade3ead9b5e12691f7693f0554323b88dc3c0cb6038c7abaf7f1291d60b97cc24daf6
44 changes: 44 additions & 0 deletions dev-libs/libsodium/libsodium-1.0.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils autotools

DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
HOMEPAGE="https://github.com/jedisct1/libsodium"
SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"

LICENSE="ISC"
SLOT="0/18"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+asm minimal static-libs +urandom cpu_flags_x86_sse4_1 cpu_flags_x86_aes"

PATCHES=( "${FILESDIR}"/${PN}-1.0.10-cpuflags.patch )

src_prepare() {
default
eautoreconf
}

src_configure() {
local myconf

# --disable-pie needed on x86, bug #512734
use x86 && myconf="${myconf} --disable-pie"

econf \
$(use_enable asm) \
$(use_enable minimal) \
$(use_enable !urandom blocking-random) \
$(use_enable static-libs static) \
$(use_enable cpu_flags_x86_sse4_1 sse4_1) \
$(use_enable cpu_flags_x86_aes aesni) \
${myconf}
}

src_install() {
default
prune_libtool_files
}

0 comments on commit f9fe722

Please sign in to comment.