Skip to content

Commit

Permalink
app-shells/mpv-bash-completion: verbump to 3.3.5.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0

Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
Coacher authored and monsieurp committed Sep 12, 2016
1 parent 81928a6 commit fa377c1
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/mpv-bash-completion/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mpv-bash-completion-0.17.tar.gz 15033 SHA256 a4c3be027ec52fef684a545a43c05f32cf512da93ae4a569d273e6e182b90ab1 SHA512 851a9f2b5e54f176fc7519a5fceace2b3281bef4062a48e108f17b83ccbd53e7b7545969be9cbccd3f093ba9ee65bd6736650f1b4d88997808a8b1df40d769eb WHIRLPOOL ba077f686d2e9ba4e819cf30f17cdca5b98b321e6c39b72a3bd7c1f5269da3d20abe7f610838a51b941fdba8c6636fc3eaae81f07fcd08f8f61f6262d2d0fab5
DIST mpv-bash-completion-3.3.4.tar.gz 18400 SHA256 393bee900e505fd40efe4e4f266b5a60de6480daf52c195033e630a5f0fb42e1 SHA512 044adaf554d1de7c9ac984c6aa4b9339fdb9f909ab64d5020f86d1e431918fa83b139fa787e4fcc8575937a824a94ce9d6abb3f69f03d540e54d9f389b4f646b WHIRLPOOL 274986f6beb9ac5f1db6fc7737277052f0057a4d7c70b00a6c42f0f419a9005db5e73d953f2e048f2abd201090bc6b3e2f247efbc3e2fd339bd1b7bab4cb7269
DIST mpv-bash-completion-3.3.5.tar.gz 18485 SHA256 45239a4ed4370236c25e611296b992da34f6e7d65f69440f0a09096472c0a2af SHA512 8d1c0726984c9ef783f964da9434dc7f984407a3c2cbfc80b379f79875a199fcc1c80465371fbce6a966e608acac1be295e5adcd51414e87ddfb82e227337d98 WHIRLPOOL 09fb0de9c3944f8ff2af83bf7653732a7b6d8d27e8ff994e6962be85c9e27330d8e72612cbf08540da2f051a869fc3c731f8d79961704c9c33b0169f0a0617a4
48 changes: 48 additions & 0 deletions app-shells/mpv-bash-completion/mpv-bash-completion-3.3.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit bash-completion-r1

DESCRIPTION="Bash completion for the mpv video player"
HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="luajit"

COMMON_DEPEND=">=media-video/mpv-0.14.0[cli]"
RDEPEND="${COMMON_DEPEND}
>=app-shells/bash-completion-2.3-r1
"
DEPEND="${COMMON_DEPEND}
!luajit? ( dev-lang/lua:* )
luajit? ( dev-lang/luajit:2 )
"

src_prepare() {
default_src_prepare
# Avoid 'mpv' make target that supports lua only.
sed -i -e 's|check: mpv|check:|' Makefile || die
}

src_compile() {
$(usex luajit 'luajit' 'lua') gen.lua > mpv || die
}

src_install() {
dobashcomp mpv
einstalldocs
}

pkg_postinst() {
if ! has_version 'x11-apps/xrandr'; then
echo
elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
echo
fi
}

0 comments on commit fa377c1

Please sign in to comment.