Skip to content

Commit

Permalink
app-admin/hcloud: add 1.47.0
Browse files Browse the repository at this point in the history
Signed-off-by: Agostino Sarubbo <[email protected]>
  • Loading branch information
asarubbo committed Sep 2, 2024
1 parent ee749d7 commit fa3effd
Show file tree
Hide file tree
Showing 2 changed files with 32 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/hcloud/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST hcloud-1.43.1.tar.xz 1889004 BLAKE2B 563cde962cf1fd180bbef60127b714419c09da198afeb4923f8fc1cd48850131b3b91de243de43e269497f36d14757a1e71941d30dfbee98baebb533f20e6cdd SHA512 c8fa46e9d3e2c73cc2d86e597bebf6e1dbf28b7145dbc272c403607807251ac27eee14b9ad267fdf2aa730da16ce52be4d2b0d94653612b4f375f1779c95d90b
DIST hcloud-1.46.0.tar.xz 2197572 BLAKE2B 35920aae5ebd1a7efe88e159717e6a494810ac5ffae6bc4f6eba1e01685d29630ebefabe48a1d7d68fc8fea0d7ca5e647fb17ce07914d3cffad3e160c81228a8 SHA512 8ba06efc60a8e4cfd4ac84105c190c3749a4f5f53ba5c416880a9eb9f6e139da46ff935ef3de560e4a39703b92f710d3ced8d0fe2d7c939b77c3b6bbff288a8d
DIST hcloud-1.47.0.tar.xz 2199764 BLAKE2B 02c06449ab62904b3f21ddaadc6182a965488e72f453b8d03d73b4be8a585ae42a7f1db4012588b8983e77cb181fa1aeff1a778205fc23731bc12565cdea1d7b SHA512 ca5999ef59a3b11e589a6c199f87ff2487b1384dfb6244adf286b84ee7de9dc6cbc4879dc72b6a5196c0f067efa7d3202110471debc4fe020114bf97ea10f9c8
31 changes: 31 additions & 0 deletions app-admin/hcloud/hcloud-1.47.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module

DESCRIPTION="A command-line interface for Hetzner Cloud"
HOMEPAGE="https://github.com/hetznercloud/cli"
SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

src_compile() {
ego build -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.versionPrerelease=gentoo" ./cmd/${PN}
}

src_test() {
# For upstream a simple test is run 'hcloud version'
./hcloud version
if [[ $? -ne 0 ]]
then
die "Test failed"
fi
}

src_install() {
dobin ${PN}
}

0 comments on commit fa3effd

Please sign in to comment.