forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-video/mediainfo: version bump to 0.7.82
- Loading branch information
Showing
2 changed files
with
73 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST mediainfo_0.7.73.tar.bz2 1467006 SHA256 a7cae29ac45a642c6747746db150382ed88e42891b3b0bcfa59648d8838fab92 SHA512 46bfcacac8fb554ee1adbe5afb65d94330dea520bfea69fb4a0099e7da9159eedfc79023a6ca300443abfdc06caa1d455ad920957bbdb6307450ced0128dcd41 WHIRLPOOL 4fd45fd4d218bab60ea7935c0743b8ccfd218eb7790d314172f89bef1b8d33b397cfcf86bbd38de57c7c9f92bf30bbc27e262959f249506d8da00ef64c2add98 | ||
DIST mediainfo_0.7.80.tar.xz 1293796 SHA256 2030a3075111c78282579c15eea8e5215717f19a8014490045d157b6098f3c8a SHA512 1ffaf931a21fa8cbd15a67d033d60a22b2ecba24870740d7a241f130303cca883c9df7b333b860a0a4a6ff6647418b4eb142cfbb97d4aad7725f5ad2ebbf7384 WHIRLPOOL b072a42564387860c5179f43e1233abb2406e0e21446f1a9391bdc5ca21fc8ab534cc15b38ddb4aa79ccdb79c976256db2edbad2852433aa64c9959fbc7e1003 | ||
DIST mediainfo_0.7.81.tar.xz 1295940 SHA256 077c9eb3471ec8a8160d154047692b001b09877bcd9bea18c4f0413c894750a9 SHA512 7ca2fccd62096ed4924ccc9bdac799a33252121ef8c634dfbbf6e547da151a4549aadf82335091d471c911c026b65ceb9bfc9d4c75dafff12c91e1fd0c41e107 WHIRLPOOL 08c87a80ce6bbd14b1060c3087834ac278ad7ff53cfb8510b313e91c16657c49c399a8f3891b692c502bdb1151fff840a502a7e948d2d249fbb8c320a5b4be37 | ||
DIST mediainfo_0.7.82.tar.xz 1297504 SHA256 62882c977f209c0a4e2cb47f2109180fbe6b5337e471a3eb728daa917aaf7b47 SHA512 d07bd35d2b6fdff5ebb6546d294362d597001625f5a6c74d987629304b58d3f20e7c750d586ca6bfb1e05f8fb1b93dbadf4799721ec777a6c03f35232a4bdc80 WHIRLPOOL 59da6119a4f610fc1416da0d443a8242dcb316b6360e120f797b1efac34587e1819b22fa39531debe257f74d0ccb8f2b2f1fb803037a485b3525ddf1a88b37a4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
WX_GTK_VER="3.0" | ||
|
||
inherit eutils autotools wxwidgets multilib | ||
|
||
DESCRIPTION="MediaInfo supplies technical and tag information about media files" | ||
HOMEPAGE="http://mediaarea.net/mediainfo/" | ||
SRC_URI="http://mediaarea.net/download/source/${PN}/${PV}/${P/-/_}.tar.xz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="curl mms wxwidgets" | ||
|
||
RDEPEND="sys-libs/zlib | ||
media-libs/libzen | ||
~media-libs/lib${P}[curl=,mms=] | ||
wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/MediaInfo | ||
|
||
pkg_setup() { | ||
TARGETS="CLI" | ||
use wxwidgets && TARGETS+=" GUI" | ||
} | ||
|
||
src_prepare() { | ||
epatch_user | ||
|
||
local target | ||
for target in ${TARGETS}; do | ||
cd "${S}"/Project/GNU/${target} | ||
sed -i -e "s:-O2::" configure.ac | ||
eautoreconf | ||
done | ||
} | ||
|
||
src_configure() { | ||
local target | ||
for target in ${TARGETS}; do | ||
cd "${S}"/Project/GNU/${target} | ||
local args="" | ||
[[ ${target} == "GUI" ]] && args="--with-wxwidgets --with-wx-gui" | ||
econf ${args} | ||
done | ||
} | ||
|
||
src_compile() { | ||
local target | ||
for target in ${TARGETS}; do | ||
cd "${S}"/Project/GNU/${target} | ||
default | ||
done | ||
} | ||
src_install() { | ||
local target | ||
for target in ${TARGETS}; do | ||
cd "${S}"/Project/GNU/${target} | ||
default | ||
dodoc "${S}"/History_${target}.txt | ||
if [[ ${target} == "GUI" ]]; then | ||
newicon "${S}"/Source/Resource/Image/MediaInfo.png ${PN}.png | ||
make_desktop_entry ${PN}-gui MediaInfo ${PN} "AudioVideo;GTK" | ||
fi | ||
done | ||
} |