Skip to content

Commit

Permalink
www-apps/karma-bin: 0.43 bump
Browse files Browse the repository at this point in the history
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
william-hubbs authored and williamh committed Aug 13, 2019
1 parent 584ec0f commit fa8574e
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-apps/karma-bin/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST karma-bin-0.33-amd64.tar.gz 14113120 BLAKE2B a37dc699d7ff26dcbb9188afc48639
DIST karma-bin-0.39-amd64.tar.gz 15071130 BLAKE2B 71edfac70d02eee3b9406fc57e335c2f9c4f68a16f32da591e70c753f1498c182f36da7c018458b54f39b00968908e56367cdf30f26815ed53e78e6710d56e76 SHA512 6ed03b3c25745fc631ca04b3659239efdce78b221eb1c9c43fb9c8f8e7d6aadc153962388b54b0209e8896f9c9cf33f1fa5a23b6ed2bfbd4c4b48c7a24ab0637
DIST karma-bin-0.40-amd64.tar.gz 14309083 BLAKE2B bdb0dff3ed308102eff8a4d7e4363901619045c39c2e154cda629aa0bd65ff6a0afee8885d3b014e6fcd448d25df1b881de4b4281efa525a73f54fbb9c425d5b SHA512 5148164b78da3e9a79eda8f203f52fd78c233993f657887d3d64fe0eaf00c90610058b3f0e8509a5d4f9f05f77b5c39461cbfa9d4ccbc9d984ba07944955756d
DIST karma-bin-0.41-amd64.tar.gz 14311961 BLAKE2B 6e16ba96c0e4c612e4b6e93397d21469a154285e14c5dce547cac02a1a04dc37ef3cb4d6070e32c322dbdc3e30c1bd4997e2c0c0ad358a238ecaf7028e65f28e SHA512 ff0ff076e5273d6b813886cdc4a8476b9bc2c9afea29f591ba0ba6f7049ea79610dfb986f532b571ffb6b90b24da1a82e770546de9ca750985055e37cc7805e3
DIST karma-bin-0.43-amd64.tar.gz 14854945 BLAKE2B f9db45563f58d615370514fa206ec45b41126c1701f4b586e7a70564e4ea65123753532c086f8f1bf3cf77160a041d87fe09c33bfe9cd8ca6263154867ee3e2b SHA512 d82beeec70d3e05301ce8b788b8e54b28e9540c9e652ee5e61188334672f5f5341ada1f63c20161c7f67216b0f74402070c849a14039de4e7eb863e688b15444
40 changes: 40 additions & 0 deletions www-apps/karma-bin/karma-bin-0.43.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
MY_PN=${PN%-bin}

inherit user

DESCRIPTION="Alerts dashboard for Prometheus Alertmanager"
HOMEPAGE="https://github.com/prymitive/karma"
SRC_URI="https://github.com/prymitive/${MY_PN}/releases/download/v${PV}/${MY_PN}-linux-amd64.tar.gz -> ${P}-amd64.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

QA_PREBUILT="usr/bin/*"
RESTRICT="strip"
S="${WORKDIR}"

pkg_setup() {
enewgroup ${MY_PN}
enewuser ${MY_PN} -1 -1 -1 ${MY_PN}
}

src_install() {
dobin karma-linux-amd64
dosym karma-linux-amd64 /usr/bin/karma
insinto /etc/${MY_PN}
newins "${FILESDIR}"/${MY_PN}-0.24.yaml ${MY_PN}.yaml
newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}
keepdir /var/log/${MY_PN}
fowners ${MY_PN}:${MY_PN} /var/log/${MY_PN}
}

pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog "Please edit ${EROOT}/etc/karma/karma.yaml to match your system."
fi
}

0 comments on commit fa8574e

Please sign in to comment.