forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-plasma/plasma-workspace: version bump 5.9.5.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
- Loading branch information
1 parent
dc4a3fa
commit fa8d9cd
Showing
2 changed files
with
164 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST plasma-workspace-5.8.6.tar.xz 6992264 SHA256 51ab8b5f4c33c83fb64eb3f27561f3699b12b5e5c9fa7d38b73d93e57da50192 SHA512 fdc22db98942db8debe24a4364b2a8c5d02ee850691a8e7788f812b6ee9b3324a26b5cb71d248f49fa71eba0aca47f838ef671dd428e26fb60a5a5650d9d3144 WHIRLPOOL 9802e399f357ca5585e1cf2b838d601d330fb1c8d97fc012c5c7dd41a2742971e0539153a78ded8fa4196a8559a17074cf74523df5b8c4f1ebe902d6432311b5 | ||
DIST plasma-workspace-5.9.5.1.tar.xz 6980684 SHA256 857770a27d3cd4af027078050d36cefc843e47f4bd92b93a712b0238d6c08b1e SHA512 064ac0e8ecdd6b8b6b1a125943dc1d1a196ff9ef108e88e71b9d5d2ac54e4f60a11535373d9f783080ac9e23fd20d0d902c7d155c65dfbcbdca036cc62c57aad WHIRLPOOL 21c85ab60dffc00468380e6ec9123d76bf803be4679bfc2107e4cdb57dafde3b3ab3f95c33c219a5edbef8b72320f5205f940477b01f8fb9e614643096b200d2 | ||
DIST plasma-workspace-5.9.5.tar.xz 6937764 SHA256 abe34e01d455b8367a58ea135be63af91122338d3129f14bc51d52887e6b6b55 SHA512 cf36b22ac9e12c76b1a427514516a82fe9e583070f114b51df6b5bb2bc2ffcdb86e3a9dcfff90a9384935ee4e106d1cf0e203ef9a0067390e8fa35b5f614a449 WHIRLPOOL 1a387528e21b05d4fd80a774a06c12e4240611c71d8c2331d0d3c8b2d5664d086c2744f75680e969ce224edf5cd49e39bbed58d0be7b52800edb1db1e8b53885 |
163 changes: 163 additions & 0 deletions
163
kde-plasma/plasma-workspace/plasma-workspace-5.9.5.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,163 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
KDE_TEST="forceoptional" | ||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 multilib qmake-utils | ||
|
||
DESCRIPTION="KDE Plasma workspace" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
IUSE="+calendar geolocation gps prison qalculate +semantic-desktop" | ||
|
||
COMMON_DEPEND=" | ||
$(add_frameworks_dep kactivities) | ||
$(add_frameworks_dep kauth) | ||
$(add_frameworks_dep kbookmarks) | ||
$(add_frameworks_dep kcmutils) | ||
$(add_frameworks_dep kcompletion) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep kdeclarative) | ||
$(add_frameworks_dep kdelibs4support) | ||
$(add_frameworks_dep kdesu) | ||
$(add_frameworks_dep kglobalaccel) | ||
$(add_frameworks_dep kguiaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kidletime) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kitemmodels) | ||
$(add_frameworks_dep kitemviews) | ||
$(add_frameworks_dep kjobwidgets) | ||
$(add_frameworks_dep kjs) | ||
$(add_frameworks_dep kjsembed) | ||
$(add_frameworks_dep knewstuff) | ||
$(add_frameworks_dep knotifications) | ||
$(add_frameworks_dep knotifyconfig) | ||
$(add_frameworks_dep kpackage) | ||
$(add_frameworks_dep krunner) | ||
$(add_frameworks_dep kservice) | ||
$(add_frameworks_dep ktexteditor) | ||
$(add_frameworks_dep ktextwidgets) | ||
$(add_frameworks_dep kwallet) | ||
$(add_frameworks_dep kwayland) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kwindowsystem) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_frameworks_dep kxmlrpcclient) | ||
$(add_frameworks_dep plasma) | ||
$(add_frameworks_dep solid) | ||
$(add_plasma_dep kscreenlocker) | ||
$(add_plasma_dep kwin) | ||
$(add_plasma_dep libksysguard) | ||
$(add_qt_dep qtconcurrent) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtdeclarative 'widgets') | ||
$(add_qt_dep qtgui 'jpeg') | ||
$(add_qt_dep qtnetwork) | ||
$(add_qt_dep qtscript) | ||
$(add_qt_dep qtsql) | ||
$(add_qt_dep qtwidgets) | ||
$(add_qt_dep qtx11extras) | ||
$(add_qt_dep qtxml) | ||
media-libs/phonon[qt5] | ||
sys-libs/zlib | ||
x11-libs/libICE | ||
x11-libs/libSM | ||
x11-libs/libX11 | ||
x11-libs/libXau | ||
x11-libs/libxcb | ||
x11-libs/libXfixes | ||
x11-libs/libXrender | ||
x11-libs/xcb-util | ||
x11-libs/xcb-util-image | ||
calendar? ( $(add_kdeapps_dep kholidays) ) | ||
geolocation? ( $(add_frameworks_dep networkmanager-qt) ) | ||
gps? ( sci-geosciences/gpsd ) | ||
prison? ( $(add_frameworks_dep prison) ) | ||
qalculate? ( sci-libs/libqalculate:= ) | ||
semantic-desktop? ( $(add_frameworks_dep baloo) ) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
$(add_frameworks_dep kded) | ||
$(add_kdeapps_dep kio-extras) | ||
$(add_plasma_dep kde-cli-tools) | ||
$(add_plasma_dep ksysguard) | ||
$(add_plasma_dep milou) | ||
$(add_plasma_dep plasma-integration) | ||
$(add_qt_dep qdbus) | ||
$(add_qt_dep qtgraphicaleffects) | ||
$(add_qt_dep qtpaths) | ||
$(add_qt_dep qtquickcontrols 'widgets') | ||
app-text/iso-codes | ||
x11-apps/mkfontdir | ||
x11-apps/xmessage | ||
x11-apps/xprop | ||
x11-apps/xrdb | ||
x11-apps/xset | ||
x11-apps/xsetroot | ||
!dev-libs/xembed-sni-proxy | ||
!kde-plasma/freespacenotifier:4 | ||
!kde-plasma/libtaskmanager:4 | ||
!kde-plasma/kcminit:4 | ||
!kde-plasma/kdebase-startkde:4 | ||
!kde-plasma/klipper:4 | ||
!kde-plasma/krunner:4 | ||
!kde-plasma/ksmserver:4 | ||
!kde-plasma/ksplash:4 | ||
!kde-plasma/plasma-workspace:4 | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
x11-proto/xproto | ||
" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-5.4-startkde-script.patch" ) | ||
|
||
RESTRICT+=" test" | ||
|
||
src_prepare() { | ||
kde5_src_prepare | ||
|
||
sed -e "s|\`qtpaths|\`$(qt5_get_bindir)/qtpaths|" \ | ||
-i startkde/startkde.cmake startkde/startplasmacompositor.cmake || die | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package calendar KF5Holidays) | ||
$(cmake-utils_use_find_package geolocation KF5NetworkManagerQt) | ||
$(cmake-utils_use_find_package gps libgps) | ||
$(cmake-utils_use_find_package prison KF5Prison) | ||
$(cmake-utils_use_find_package qalculate Qalculate) | ||
$(cmake-utils_use_find_package semantic-desktop KF5Baloo) | ||
) | ||
|
||
kde5_src_configure | ||
} | ||
|
||
src_install() { | ||
kde5_src_install | ||
|
||
# startup and shutdown scripts | ||
insinto /etc/plasma/startup | ||
doins "${FILESDIR}/10-agent-startup.sh" | ||
|
||
insinto /etc/plasma/shutdown | ||
doins "${FILESDIR}/10-agent-shutdown.sh" | ||
} | ||
|
||
pkg_postinst () { | ||
kde5_pkg_postinst | ||
|
||
echo | ||
elog "To enable gpg-agent and/or ssh-agent in Plasma sessions," | ||
elog "edit ${EPREFIX}/etc/plasma/startup/10-agent-startup.sh and" | ||
elog "${EPREFIX}/etc/plasma/shutdown/10-agent-shutdown.sh" | ||
echo | ||
} |