Skip to content

Commit

Permalink
media-libs/lib3mf: bump to 2.1.0
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/769275
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Bernd Waibel <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
waebbl authored and juippis committed Mar 7, 2021
1 parent 97f6655 commit fac05c2
Show file tree
Hide file tree
Showing 3 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/lib3mf/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lib3mf-1.8.1.tar.gz 8415939 BLAKE2B 45652aab8c84eb5d500455db211eb911c6e74decf4fbbb652976847e1b3ea16db9c626bd37cd9669aefc8dea29c424e6518e0517e8f96fa6282771e34f840290 SHA512 f7fd75bcb6472de1595a018e5add516d0d78ab0aee92462b686b77f8d2bef05270e7b737cb7e1d31fc5850815056e753874c2f9ec456a455e8461c4010fe914a
DIST lib3mf-2.1.0.tar.gz 15882048 BLAKE2B 9466e1fd30d82600dcc52f61709c1430ae3c129358225162a343ec0d7f489e14572882a9c5239ccd63ea66ee7faec1563fa5aa0e788f28d18ad96db0ae7b9f36 SHA512 05f92da9cbbac279baf33fe3a7ce43ff7faad987c4ba08120094406e1a8f9bab2330b47822fa0a84d1558be9c829f3e805782a46ed85b706e7f85cb861d0d4f5
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 13f974157b178efe4c6d617f23246dde2b100f0d Mon Sep 17 00:00:00 2001
From: Bernd Waibel <[email protected]>
Date: Wed, 10 Feb 2021 18:49:14 +0100
Subject: [PATCH] [Gentoo-specific] avoid pre-stripping library

Signed-off-by: Bernd Waibel <[email protected]>
---
CMakeLists.txt | 3 ---
1 file changed, 3 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c8b4ba..05d493f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -182,9 +182,6 @@ if (UNIX OR MINGW)
# Uncomment the following to put the version info into the .so-file.
set_target_properties(${PROJECT_NAME} PROPERTIES VERSION "${LIB3MF_VERSION_MAJOR}.${LIB3MF_VERSION_MINOR}.${LIB3MF_VERSION_MICRO}.${BUILD_NUMBER}")
set_target_properties(${PROJECT_NAME} PROPERTIES SOVERSION "${LIB3MF_VERSION_MAJOR}")
- if (NOT APPLE)
- set_target_properties(${PROJECT_NAME} PROPERTIES LINK_FLAGS -s)
- endif()
else()
# wd4996 masks the deprecated-warning
target_compile_options(${PROJECT_NAME} PUBLIC "$<$<CONFIG:DEBUG>:/Od;/Ob0;/sdl;/W3;/WX;/FC;/wd4996>")
--
2.30.1

66 changes: 66 additions & 0 deletions media-libs/lib3mf/lib3mf-2.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

DESCRIPTION="Implementation of the 3D Manufacturing Format file standard"
HOMEPAGE="https://3mf.io/"
SRC_URI="https://github.com/3MFConsortium/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0/2"
# the included ACT binary is a statically x86_64 built one
# see https://github.com/3MFConsortium/lib3mf/issues/199
# no package available for ACT yet in Gentoo.
# Keywords x86 and arm64 can be re-added after we have a package
KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
dev-libs/libzip:=
sys-apps/util-linux
sys-libs/zlib
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
test? (
dev-cpp/gtest
dev-libs/openssl
dev-util/valgrind
)
"

PATCHES=(
"${FILESDIR}"/${P}-0001-Gentoo-specific-avoid-pre-stripping-library.patch
)

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_INCLUDEDIR="include/${PN}"
-DLIB3MF_TESTS=$(usex test)
-DUSE_INCLUDED_LIBZIP=OFF
-DUSE_INCLUDED_ZLIB=OFF
)

if use test; then
mycmakeargs+=(
-DUSE_INCLUDED_GTEST=OFF
# code says it uses libressl, but works with openssl too
-DUSE_INCLUDED_SSL=OFF
)
fi

cmake_src_configure
}

src_install() {
local DOCS=( CONTRIBUTING.md README.md )
cmake_src_install

cd "${ED}/usr/include/${PN}" || die
ln -sf Bindings/Cpp/${PN}_{abi,types,implicit}.hpp . || die
}

0 comments on commit fac05c2

Please sign in to comment.