forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-cpp/rapidfuzz-cpp: Bump to 1.9.0
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
43 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST rapidfuzz-cpp-1.7.0.gh.tar.gz 252646 BLAKE2B 5d79c07e26b6bb8e84d3280c3401bad60a3ca9846977a5bf9b13787ed7951c3805c71b7e6e2e03b14e2b988381484d969e1cc885c316bcb805b403e53332b31b SHA512 ed8af678a40161aa738bd3606b41fd54c1dba603c47fbdb1182527abd5667736e50f458af252e7bde954f263040cdbd662ad1c6be0a5caa5289f0a351dfd6d9e | ||
DIST rapidfuzz-cpp-1.8.0.gh.tar.gz 280419 BLAKE2B ae6b7694df3f8ba97b369608bb02783bdd48572e80a9d4f0ee51585975aaee1c0ee058862b94a7a8e46f835b03c04d134143ed07fb5c6d412b4b5cff8686c6d3 SHA512 35729c90494b419fefd9c6bbd03e42cc485d421defcd65bf5dee776d4d0756318a90456980914ccebc100b1bb388474db54638a8628efd496764c604d6221688 | ||
DIST rapidfuzz-cpp-1.9.0.gh.tar.gz 281385 BLAKE2B 4afc48edd9c8270200645eb77065bf212b9579b90b3916e261bbe69fd60f67c1e510c3ae4ef9877a26c3313063717b362e01c6cf799a0f9fc3429799d9b2dca6 SHA512 d95c90f9118811d650d859a20f847c71427acbc8c4f907f49d23b069cd6d1a848749d32f8fbff7326828b7a030c3f488acacba5845a72a0057ccf4c3088badf4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit cmake | ||
|
||
DESCRIPTION="Rapid fuzzy string matching in C++" | ||
HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/" | ||
SRC_URI=" | ||
https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz | ||
-> ${P}.gh.tar.gz | ||
" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~riscv" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
BDEPEND=" | ||
test? ( | ||
>=dev-cpp/catch-3 | ||
) | ||
" | ||
|
||
src_prepare() { | ||
# apparently "C++ best practices" don't mind fetching random stuff | ||
# at build time | ||
sed -i -e '/aminya/,/^)/d' test/CMakeLists.txt || die | ||
find -name 'CMakeLists.txt' -exec \ | ||
sed -i -e 's:project_warnings::' {} + || die | ||
|
||
cmake_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DRAPIDFUZZ_BUILD_TESTING=$(usex test) | ||
) | ||
cmake_src_configure | ||
} |