Skip to content

Commit

Permalink
dev-python/pytest-django: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Nov 9, 2015
1 parent 98c9cbc commit faeba16
Show file tree
Hide file tree
Showing 2 changed files with 32 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pytest-django/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pytest-django-2.8.0.tar.gz 15405 SHA256 d145ac9dc7a557a719ab79770be0941004e1e038e137c34591919d9df2a790b1 SHA512 bc692f1b3112e07f435db746328fea18b78e71fecbded26a4e68f7dbd9b84698d193a3d191d1039a3ff23e88d2dbf4beb0d08e382fbde333033b8b54fbe99dee WHIRLPOOL 1bc9b446a826bfa5c842dc40efb9f51a16dba1e9a3e5f2c1cc7afb6a34ffd69ed2a4a3be197fbf23bc7425773acb71bda4bcfebae6189f06fc95ac2219250d13
DIST pytest-django-2.9.1.tar.gz 50570 SHA256 8be15b637738c8cbd1422a6461465c0aeab7839cf76ad2b5d190b6f1f53facd6 SHA512 0e50f45a0cfefb6fa74f7d60d5173e3e8dac49ac669c9c88e46d27a01cff5c4a255d6f707863406b6f8707e25e9bea3408cbffbb75a2680fee365b9c9167d468 WHIRLPOOL b7992224d0cfb655c9faf0af9689a6bdd2c9371114c875f2b1a00e6d972a487346cb6939eac0b04d24b302311d1795696f5c38e362f832a84416d2a0d23b501d
31 changes: 31 additions & 0 deletions dev-python/pytest-django/pytest-django-2.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="A Django plugin for py.test"
HOMEPAGE="https://pypi.python.org/pypi/pytest-django https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"

RDEPEND=""
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.8.0[${PYTHON_USEDEP}]
"

# https://github.com/pytest-dev/pytest-django/issues/290
RESTRICT=test

python_test() {
PYTEST_PLUGINS=${PN/-/_} \
py.test --ds=pytest_django_test.settings_sqlite_file --strict -r fEsxXw || die
}

0 comments on commit faeba16

Please sign in to comment.