Skip to content

Commit

Permalink
dev-python/lxml: version bump to 4.2.2
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Jun 26, 2018
1 parent d9c8635 commit fb118ea
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/lxml/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST lxml-3.8.0.tar.gz 3795205 BLAKE2B 39f3edc7efe48bd569b636de89cfcd8f7e4e88e025fd5c21164e35edf110546112844a4ddb6cb1842649fb165de3b3880b0fdb7a23522a891b35390adf64c95b SHA512 08f6f352e22ed2bc199a5f34a1c6b5f7b41ec282dc0026c9f16a06466c27e39e8eb18608ba4493636170eeac4b0194f7050445e1cc9bd0a4628573c404593088
DIST lxml-4.1.1.tar.gz 2380804 BLAKE2B 4d3c4ef0472c7af7bb4185142a8274b596dd55a908d41f5295d0a78031a7efb3aef8893ca739f8db0675e44d4b0c346746a2758d31a54825c06a153203599ab9 SHA512 9542e5206f9b2f9e072c52ef8e6cf44d1aaae8ae3e7ca7e820c1fac12e716503308ccb3cebc52155b4c93799f3ebca247781fc491524d004378bd26f5cddb9d1
DIST lxml-4.2.0.tar.gz 4282112 BLAKE2B 5dd68d984097253fac4c35d59e7b687fa1bc0699946accb66687b94e0b3d807c7c555795486828307ccbadd87aa989b6bba2d2fc71cec27e8b8e52f2762c5548 SHA512 89c7dd5d36e8816008b22b25bb02275a008fcfe26f6fdeff139ac8394bd773035bf423b9d7c4233f19985e5a8c12f936b71096c55e28957e97da0810d88de8d3
DIST lxml-4.2.2.tar.gz 4417798 BLAKE2B 9344e0d261d2d40d43e67d4f162ce7da466c924dc1ad69d7eca602c14d789c6531747079cc92058e28f320c8695a64333b5044d37fecb8c713b0feac97ecef90 SHA512 4723c70edfa97069cb476d30e4f9c97f77c560302bdb547b6c4b0e7eb8610dc28a5e47c99bba6d780fd7b1510c0daa5cfb2da40542aab4415ea59c2a378a6b71
73 changes: 73 additions & 0 deletions dev-python/lxml/lxml-4.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )

inherit distutils-r1 eutils toolchain-funcs

DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
HOMEPAGE="http://lxml.de/ https://pypi.org/project/lxml/ https://github.com/lxml/lxml"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD ElementTree GPL-2 PSF-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="doc examples +threads test"

# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
RDEPEND="
>=dev-libs/libxml2-2.9.5
>=dev-libs/libxslt-1.1.28"
DEPEND="${RDEPEND}
virtual/pkgconfig
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
"

DISTUTILS_IN_SOURCE_BUILD=1

PATCHES=(
"${FILESDIR}"/${PN}-3.5.0-cross-compile.patch
)

python_prepare_all() {
# avoid replacing PYTHONPATH in tests.
sed -i '/sys\.path/d' test.py || die

distutils-r1_python_prepare_all
}

python_compile() {
if ! python_is_python3; then
local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
fi
tc-export PKG_CONFIG
distutils-r1_python_compile
}

python_test() {
cp -r -l src/lxml/tests "${BUILD_DIR}"/lib/lxml/ || die
cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
ln -s "${S}"/doc "${BUILD_DIR}"/ || die

"${EPYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
}

python_install_all() {
if use doc; then
local DOCS=( README.rst *.txt doc/*.txt )
local HTML_DOCS=( doc/html/. )
fi
if use examples; then
dodoc -r samples
fi

distutils-r1_python_install_all
}

pkg_postinst() {
optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
}

0 comments on commit fb118ea

Please sign in to comment.