Skip to content

Commit

Permalink
dev-python/six: Bump to 1.12.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 10, 2018
1 parent d8979a7 commit fb11fc3
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/six/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST six-1.10.0.tar.gz 29630 BLAKE2B 1f380dbc7a9e746b4a7909de54a58a008a73d7b6c582611b2481475d5d9971c936b1742ea0821c65150694914af72f43155caa54616268735a4bd2447d5b4ba4 SHA512 9a53b7bc8f7e8b358c930eaecf91cc5639176a699830153f586780c3e6d637f1bd31349a69c383574f99da19cb3a36524e7733a318f3572b27aefb69c6409c2e
DIST six-1.11.0.tar.gz 29860 BLAKE2B de4886ad9af7aa906f9eac213544c99323d74c1988d9abff96ce6fc3eea4464e577511f7c52328cbd9e6989db2128fa8d1ee57f9ce7bfc36b83ff655691b46c9 SHA512 33f246a2e987141e17e5edad9d3537cf3aba0cbdd0bc2a907ea52ce0d674b1474f29c3dd5cc26605fd960396054b189ca5f501708333cad234c223131483fe24
DIST six-1.12.0.tar.gz 32725 BLAKE2B f40621076a7bb2b3b86d9f6ee49056a598e4853c6150952902053b8cfde86e562a7656b6ca3c3108f407d392cf7c1164a61b36142efd565eda909b8733c0bedb SHA512 937728372edf1e0ac13bbd706723d0de35e015c30d0ae41f789c5ed2e3669bb0db70cdc6e036ec2d437a6c4aa0d5d1e727b6d09ac34cca7e4e92e5d3b4775151
39 changes: 39 additions & 0 deletions dev-python/six/six-1.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )

inherit distutils-r1

DESCRIPTION="Python 2 and 3 compatibility library"
HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"

PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)

python_compile_all() {
use doc && emake -C documentation html
}

python_test() {
pytest -vv || die "Testing failed with ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( documentation/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit fb11fc3

Please sign in to comment.