Skip to content

Commit

Permalink
app-admin/mcollective: 2.10.3 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
prometheanfire committed Apr 5, 2017
1 parent 383b71a commit fb3a1bb
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/mcollective/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mcollective-2.10.1.tar.gz 1509293 SHA256 b47662b8ab3f150df6153f18c453bad049d8baf0cc8b5589436ae411258492fc SHA512 907bc4bb8527053f0813d19fd9a2fd19701af364d45385356772b09f3db50fd8c4d8e4e53ad9c3ad7c53c78bed52fcfec2354505272302c770c9cfea553309c5 WHIRLPOOL 4e283c42ae8f4161a47e95e1fc223d47fed3bc5308df09b3bd43a7b7d90e1927c2a6067faa872404e261f7e4597e900b7c994266587e8a73c53420d90614b6c6
DIST mcollective-2.10.2.tar.gz 1509434 SHA256 ea067ad540db608ae17a569e74104b26f13e528b78ec6367c2fcfb30b8cea500 SHA512 f3a2dd430c13d77ab09d75f50dd5ab8244a9697a5132ef234fe63a9120acbfc917abcfb7fb26d2ca4c4c86cc554889e3f3a6e651283b0d35f72bb7038dd813e6 WHIRLPOOL 9bf6b28d01d0fa593731b024895adc5f0d92504cf9cf2db02ae94fd8654dd6410b7ef46079632a1aadf702fc7470cf58c47e6bd68f7fb6c15834f9e9b16d3d08
DIST mcollective-2.10.3.tar.gz 1509914 SHA256 1de8531a286754a5490b1acd18565bbb6aace1720743c9d7503ef8b587de1c79 SHA512 ee053fa4cb38b1f8d5b5a91c4a6980095039210443b4dc6a5468f1dcba9749152e5feeaeb437660d65e118f8d7a99f7f5082f4c83f4260dfb4ac9d6c007ce638 WHIRLPOOL 75b5111c9593c832af1f96fa5200d5c2300eed99ff8c03c579520a69f88afee34afe37f7d8362f72f46f6e591595ea68433d01960453292766afb0441bad7d2f
DIST mcollective-2.9.1.tar.gz 1504607 SHA256 89bc9fbd72846b22220074a57d19bbfac56473649078fc3ac8182cc728159249 SHA512 29fedacb61084e1952afd3b9deb302abde3e763d13630d85dc70f78b0853f5b353fb44ccbd00e48e5864d04bf2c7568d7cbe21b06af31e1da72e52aeef3c04cf WHIRLPOOL 8affee96fa344d12b34b5a4e120029ab315133df6fd6cd456d840ab608ceb2027b9411a6a1a74bc5b9d0b029968255a926de888b7a2a1183d1c7aed195f65f7a
60 changes: 60 additions & 0 deletions app-admin/mcollective/mcollective-2.10.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

USE_RUBY="ruby21 ruby22 ruby23"

inherit ruby-ng

DESCRIPTION="Framework to build server orchestration or parallel job execution
systems"
HOMEPAGE="http://marionette-collective.org/"
SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/all/marionette-collective-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc +client"

DEPEND=""
RDEPEND="dev-ruby/stomp"

src_compile() {
einfo "nothing to compile"
}

each_ruby_install() {
cd "marionette-collective-${PV}"
doruby -r lib/*
insinto /usr/share/mcollective
use client && dosbin bin/mco
dosbin bin/mcollectived
if use doc ; then
dohtml -r doc/*
insinto /usr/share/doc/${P}/ext
doins -r ext/*
fi
newinitd "${FILESDIR}"/mcollectived.initd mcollectived
insinto /etc/mcollective
cd etc
for cfg in *.dist ; do
newins "${cfg}" "${cfg%%.dist}"
sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
"${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
done
insinto /etc/mcollective/plugin.d
}

pkg_postinst() {
einfo "Mcollective requires a stomp server installed and functioning before"
einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
einfo "any other stomp compatible server should work."
einfo
einfo "It is recommended you read the \'getting started\' guide [2] if this"
einfo "is a new installation"
einfo
einfo "[1] http://activemq.apache.org/"
einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
}

0 comments on commit fb3a1bb

Please sign in to comment.