Skip to content

Commit

Permalink
app-crypt/letsencrypt: Version bump. Fix SRC_URI
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
mrueg committed Dec 20, 2015
1 parent 0a34cb6 commit fb851f6
Show file tree
Hide file tree
Showing 3 changed files with 48 additions and 1 deletion.
1 change: 1 addition & 0 deletions app-crypt/letsencrypt/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST letsencrypt-0.1.0.tar.gz 524821 SHA256 1c1ac7b41e5e0fc0e41a7ef159ac9147a4aafff54453d57b519eb05bf52ade14 SHA512 6a786290362741ac97dcb4b59bc4cba56f3e8b5193bbc10be19086d462f76e6124259c42bac36afe9eb818f4bb9edec34f8e2a02bd8c855e3b35404f4ee81f96 WHIRLPOOL cdc41a3466de54ab8ddfeedea9935205d78383028769dcfbc876be0c2ef80c2d14f5d0e4a9c56a751163718f5ababb07848822989a060de7031ea8ebdf6424a0
DIST letsencrypt-0.1.1.tar.gz 533715 SHA256 3f5210fc2e28577b1b24c4fbfb5c20ac259925a5fad81cf69a1b4f62d76511db SHA512 bd045622f77272447b9d497c410a128c30371c6df5beab418089c2c8b26fef9e87ecc6055bdf4017d7d2fb5f840b4900ff9efba848d07a2bf3a1be9d7fc0df99 WHIRLPOOL b89bcbf1dea41bd0a391cc3db86c4a7413cdf9c5e64c2398b60b7c57c5950c221bd64a51f773a7fb2fc725d93f3d672170c97147d5b5b644a008309e95dd8576
46 changes: 46 additions & 0 deletions app-crypt/letsencrypt/letsencrypt-0.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=(python2_7)

if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
inherit git-r3
KEYWORDS=""
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

inherit distutils-r1

DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="test"

RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
dev-python/configargparse[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
>=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/parsedatetime[${PYTHON_USEDEP}]
>=dev-python/psutil-2.1.0[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
>=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"

python_test() {
nosetests -w ${PN}/tests || die
}
2 changes: 1 addition & 1 deletion app-crypt/letsencrypt/letsencrypt-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ if [[ ${PV} == 9999* ]]; then
inherit git-r3
KEYWORDS=""
else
SRC_URI="https://github.com/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

Expand Down

0 comments on commit fb851f6

Please sign in to comment.