Skip to content

Commit

Permalink
app-misc/workrave: Version bump, autoconf-archive needed (#580460 by …
Browse files Browse the repository at this point in the history
…Jeremy Stephens).

Package-Manager: portage-2.3.0
  • Loading branch information
pacho2 committed Aug 4, 2016
1 parent 7371ace commit fbbdab8
Show file tree
Hide file tree
Showing 4 changed files with 143 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-misc/workrave/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST workrave-1.10.15.tar.gz 6375380 SHA256 fa05bedbb32baae9d22ef2b1ac25e90bc9f1363ce588b396190b0240559f471c SHA512 e741f5d0748ffaba9c8e69bcbd67f7b371424423ec8cea81d082462e8c33751c3e322301ae0749037668dc53cab28b19ec2b162f98eb7afbbd5ab85bae33cf7e WHIRLPOOL 02c9f25f06ae0753f7edc418ade789c82bf39736b975e755265a86b2677842098efc966530cf9063401e2e63d9f1670e4fd4ba5d9b635d05faa5cc71b9146afa
DIST workrave-1.10.8.tar.gz 6370506 SHA256 15e0c87c2172dc249031d97d4020ee4a47ea9073aa26dc06a4b15e91abf88479 SHA512 67c3725627b42c5b32a61eb4e62e45b4a802806217ddb311ee2b610d281f9c521f69cc4da0db5ded63c99691d9f5c272493a911ba504f335508ac64945cd7403 WHIRLPOOL 9fe2c6dbd2abacc76190dac94ed334bb8ecad1dfb714afa6fee69cbbeae3981f960113dce52b54fb6935bacb29d7ad3939b4aba6ef6323b93d05b56b166edb7e
31 changes: 31 additions & 0 deletions app-misc/workrave/files/workrave-1.10.15-gsettings.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
From e0516ff9a2a49b3fa5698ab1902b2579609c45b5 Mon Sep 17 00:00:00 2001
From: Sebastian Wagner <[email protected]>
Date: Fri, 13 May 2016 23:32:35 +0200
Subject: [PATCH] Fix ifdef in GSettings hh, so gconf headers work

Signed-off-by: Sebastian Wagner <[email protected]>
---
backend/src/GSettingsConfigurator.hh | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/backend/src/GSettingsConfigurator.hh b/backend/src/GSettingsConfigurator.hh
index 9b8c5d6..3974396 100644
--- a/backend/src/GSettingsConfigurator.hh
+++ b/backend/src/GSettingsConfigurator.hh
@@ -17,8 +17,8 @@
// along with this program. If not, see <http://www.gnu.org/licenses/>.
//

-#ifndef GCONFCONFIGURATOR_HH
-#define GCONFCONFIGURATOR_HH
+#ifndef GSETTINGSCONFIGURATOR_HH
+#define GSETTINGSCONFIGURATOR_HH

#include <string>
#include <map>
@@ -69,4 +69,4 @@ private:
};


-#endif // GCONFCONFIGURATOR_HH
+#endif // GGSETTINGSCONFIGURATOR_HH
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- configure.ac.old 2015-10-24 10:11:47.469290574 +0200
+++ configure.ac 2015-10-24 10:14:35.918680898 +0200
--- a/configure.ac.old 2015-10-24 10:11:47.469290574 +0200
+++ b/configure.ac 2015-10-24 10:14:35.918680898 +0200
@@ -884,20 +884,12 @@
if test "x$enable_gstreamer" != "xno";
then
Expand Down
109 changes: 109 additions & 0 deletions app-misc/workrave/workrave-1.10.15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 )

inherit autotools gnome2 python-single-r1 versionator vcs-snapshot

DESCRIPTION="Helpful utility to attack Repetitive Strain Injury (RSI)"
HOMEPAGE="http://www.workrave.org/"
MY_PV=$(replace_all_version_separators '_')
SRC_URI="https://github.com/rcaelers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"

# dbus support looks to be used only for trying to use panel applets on gnome3!
IUSE="ayatana doc gnome gstreamer introspection mate nls pulseaudio test xfce"
REQUIRED_USE="ayatana? ( introspection )"

RDEPEND="
>=dev-libs/glib-2.28.0:2
>=x11-libs/gtk+-3.0:3[introspection?]
>=dev-cpp/gtkmm-3.0.0:3.0
>=dev-cpp/glibmm-2.28.0:2
>=dev-libs/libsigc++-2.2.4.2:2
ayatana? (
>=dev-libs/libdbusmenu-0.4[gtk3,introspection]
>=dev-libs/libindicator-0.4:3 )
gnome? ( >=gnome-base/gnome-shell-3.6.2 )
gstreamer? (
media-libs/gstreamer:1.0[introspection?]
media-libs/gst-plugins-base:1.0[introspection?]
media-plugins/gst-plugins-meta:1.0 )
introspection? ( dev-libs/gobject-introspection:= )
mate? ( mate-base/mate-applets )
pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
xfce? (
>=x11-libs/gtk+-2.6.0:2[introspection?]
>=xfce-base/xfce4-panel-4.4 )
x11-libs/libXScrnSaver
x11-libs/libSM
x11-libs/libX11
x11-libs/libXtst
x11-libs/libXt
x11-libs/libXmu
"
# dbus? (
# >=sys-apps/dbus-1.2
# dev-libs/dbus-glib )

DEPEND="${RDEPEND}
dev-python/cheetah
>=dev-util/intltool-0.40.0
sys-devel/autoconf-archive
x11-proto/xproto
x11-proto/inputproto
x11-proto/recordproto
virtual/pkgconfig
doc? (
app-text/docbook-sgml-utils
app-text/xmlto )
nls? ( >=sys-devel/gettext-0.17 )
"

pkg_setup() {
python-single-r1_pkg_setup
}

src_unpack() {
vcs-snapshot_src_unpack
}

src_prepare() {
# Fix gstreamer slot automagic dependency, bug #563584
# http://issues.workrave.org/show_bug.cgi?id=1179
eapply "${FILESDIR}"/${PN}-1.10.6-automagic-gstreamer.patch

# Fix build issue, fixed in next release.
eapply "${FILESDIR}"/${P}-gsettings.patch

eautoreconf
gnome2_src_prepare
}

src_configure() {
# gnet ("distribution") is dead for ages and other distributions stopped
# relying on it for such time too.
gnome2_src_configure \
--disable-dbus \
--disable-distribution \
--enable-exercises \
--disable-experimental \
--disable-gnome2 \
--disable-static \
--disable-xml \
$(use_enable ayatana indicator) \
$(use_enable doc manual) \
$(use_enable gnome gnome3) \
$(use_enable gstreamer) \
$(use_enable introspection) \
$(use_enable mate) \
$(use_enable nls) \
$(use_enable pulseaudio pulse) \
$(use_enable test tests) \
$(use_enable xfce)
}

0 comments on commit fbbdab8

Please sign in to comment.