Skip to content

Commit

Permalink
dev-lang/lazarus: 1.6.0 version bump bug #553650
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Amynka committed Feb 21, 2016
1 parent dfb83de commit fbe3449
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/lazarus/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST lazarus-1.0.12-0.tar.gz 47687878 SHA256 542ddd60f4a404d7020ed6962a545db910a
DIST lazarus-1.2.2-0.tar.gz 51558117 SHA256 ac2154c38b3918a08d762977073e606c272c5d4ba5cb4805bf8cd25965f3bd58 SHA512 ed6d228eae355860a8608263205ce00569785f8e39e06990fe8f17a5d070c05e2602d42e9258e42b0345f857e02b287083898f56dc5f4069157c9bace136988c WHIRLPOOL 514b9eac0bd59a0621d6c30f16d9d78f384dd6efddda163ee97b73ab24a42e6e630ec8fa17bc271b02a209618cd104ccb98d07637c67035a84141f148945cacb
DIST lazarus-1.2.4-0.tar.gz 51606253 SHA256 e8622f2b29988514c9b7b7ff6cf2058a8b73e9ef0fd7998c82e1e958d2347d28 SHA512 c1858a2b89402d3cfb4baa704cdeb51dc541bf5dcac91230f93f62035988b5e5fec3851bf033876128db5da18713389a9eb6ca73c944dae36c0d6fb30e7727f8 WHIRLPOOL fddb4d650e3400b2fe1cfde1d431be3d752f81dbe715b821f55368628097225ce9156e4065f58c27346cba5a041127c25e7cc80ca15b77aab9e6188cfdd3b215
DIST lazarus-1.2.6-0.tar.gz 51618690 SHA256 c0c7e648716f27edd6f1adf908fd5733654c3cd3db6458582ccd4343a8605eea SHA512 f7f227621ee69b7056dd87dab19e2217496ac2f280e3aa6dacdac890e55dfb9595a0562c06e50cb4b4f50d021739785d840eb19ec6d77040febb86fe78a5a47a WHIRLPOOL aff1abb59380553e92d956d35393689eed55bd8684a8c182b048cea774236defe9107b0449131a7868526721658f72e7d0c68578a55d56e53e3a68dc7d51fe3a
DIST lazarus-1.6.0-0.tar.gz 55911739 SHA256 cbce02be1ed902a4978a13144446023d955c0db69a1dba42c93a83b8a24f3ca8 SHA512 6ac84325aa2caf7896b3cb55df72199ab04bf25320257510b288cde8fb679161834dca9ad3d07d39c164c05ab35c0cd248651a13c826d454c0dc84a558589576 WHIRLPOOL 2e3b1ac39fd79dcb457bfbe22c73ddcf781e9e5f0c263d88bd9b6e2ff9e417f2e1094702e1bc190788a1f5a86470b8165bc586f22d02a8b370db9245cfd9131e
75 changes: 75 additions & 0 deletions dev-lang/lazarus/lazarus-1.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils

FPCVER="2.6.4"

DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi"
HOMEPAGE="http://www.lazarus.freepascal.org/"
SRC_URI="https://sourceforge.net/projects/${PN}/files/Lazarus%20Zip%20_%20GZip/Lazarus%201.6/${P}-0.tar.gz"

LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="minimal"

DEPEND=">=dev-lang/fpc-${FPCVER}[source]
net-misc/rsync
x11-libs/gtk+:2
>=sys-devel/binutils-2.19.1-r1:="
RDEPEND="${DEPEND}
!=gnome-base/librsvg-2.16.1"

RESTRICT="strip" #269221

S=${WORKDIR}/${PN}

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch

# Use default configuration (minus stripping) unless specifically requested otherwise
if ! test ${PPC_CONFIG_PATH+set} ; then
local FPCVER=$(fpc -iV)
export PPC_CONFIG_PATH="${WORKDIR}"
sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
#sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
fi
}

src_compile() {
LCL_PLATFORM=gtk2 emake \
$(usex minimal "" "bigide") \
-j1
}

src_install() {
diropts -m0755
dodir /usr/share
# Using rsync to avoid unnecessary copies and cleaning...
# Note: *.o and *.ppu are needed
rsync -a \
--exclude="CVS" --exclude=".cvsignore" \
--exclude="*.ppw" --exclude="*.ppl" \
--exclude="*.ow" --exclude="*.a"\
--exclude="*.rst" --exclude=".#*" \
--exclude="*.~*" --exclude="*.bak" \
--exclude="*.orig" --exclude="*.rej" \
--exclude=".xvpics" --exclude="*.compiled" \
--exclude="killme*" --exclude=".gdb_hist*" \
--exclude="debian" --exclude="COPYING*" \
--exclude="*.app" \
"${S}" "${ED%/}"/usr/share \
|| die "Unable to copy files!"

dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
dosym ../share/lazarus/startlazarus /usr/bin/lazarus
dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
use minimal || dosym ../share/lazarus/components/chmhelp/lhelp/lhelp /usr/bin/lhelp
dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png

make_desktop_entry startlazarus "Lazarus IDE" "lazarus" || die "Failed making desktop entry!"
}

0 comments on commit fbe3449

Please sign in to comment.