forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ruby/archive-tar-minitar: add 0.6.1, fixing bug 607110
Package-Manager: portage-2.3.3
- Loading branch information
Showing
2 changed files
with
30 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST minitar-0.5.4.gem 23552 SHA256 6aae3dafcf83b5d3f4f2485edbca202a0ae054ba2e3b204c24cc07dcaa93edee SHA512 e629e48b12f2dac1229ee1fd1f6fa5b5b7707d7a0298f90778767b1456b78f26fadb37e90e44bba2fd60a2541544f47cb430d19c87abc1a87c3be6843fbcb5aa WHIRLPOOL c6df959de613396168212c9b92b058b66ccca95efb16f40c40ebaf89eb20776b11a07f6d4b9c53c31234d6b33bccca573312d68c206734e10be00c5a1d4b5c86 | ||
DIST minitar-0.6.1.gem 29184 SHA256 df5cdcdd5ecdcc1100cf3513557748f726bb1feea55f5cc25bb5a7116f069ddd SHA512 e8a4acd8c831ef587d9571376ae111454faba1d6d4db5c88f2087c84d3dbb5487cdcac8ad47c5f717e195262b95040a9ee72cdaeaad23715b8a1270baec6ec70 WHIRLPOOL c8c0a7040482df9c4a0452491dfbae8c1b32e9cbb7ff98a81d4e39634a5e2a493e0abc682a60ce046fee9d54186fdd6f922c0570a38f36ae0438b3f62b699c59 |
29 changes: 29 additions & 0 deletions
29
dev-ruby/archive-tar-minitar/archive-tar-minitar-0.6.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
USE_RUBY="ruby21 ruby22 ruby23 ruby24" | ||
|
||
RUBY_FAKEGEM_TASK_TEST="" | ||
RUBY_FAKEGEM_TASK_DOC="" | ||
|
||
RUBY_FAKEGEM_EXTRADOC="History.md README.rdoc" | ||
|
||
# We don't use RUBY_FAKEGEM_NAME here since for now we want to keep the | ||
# same gem name. | ||
|
||
inherit ruby-fakegem | ||
|
||
DESCRIPTION="Provides POSIX tarchive management from Ruby programs" | ||
HOMEPAGE="https://github.com/halostatue/minitar" | ||
SRC_URI="mirror://rubygems/minitar-${PV}.gem" | ||
|
||
LICENSE="|| ( BSD-2 Ruby )" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris" | ||
IUSE="" | ||
|
||
each_ruby_test() { | ||
${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die | ||
} |