Skip to content

Commit

Permalink
app-backup/deja-dup: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
pacho2 committed May 29, 2016
1 parent 6deb2d2 commit fc4523c
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/deja-dup/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST deja-dup-34.0.tar.xz 670644 SHA256 a12da41c989c1fdf43e430965efe8934b0ed9919aab29b372ef7edcedd9fd468 SHA512 70e1b7bb9490acba2b3f2656bc3210a6278a28be3cb8fa4a05feb4b9a88bf8f3728a25d09023bae6203124a38dd71c931d245eaa8302fa0ebf3322151b9f79ba WHIRLPOOL 3661ff7f63049f816f606cb7b11303fed6cb48fb1ec2e78a0dc9260ddb6b267526ef06e658794578a8bccb9d5db370d485f33ae9411aa07efb8accb8e3ae720b
DIST deja-dup-34.1.tar.xz 3716548 SHA256 c5469aa6c4d86e5cfc34664549b84b8cc555ece95551e1147029f738a877e551 SHA512 490686df0cae99e3a70db4af1697163124d3bab6af446f1c72a5de643ff63031fba67ee2531000fa748f39344e8ec492680c37370ba29a4ccd061bb5e751cb13 WHIRLPOOL 77d947d27f38247801050f8128dc286caf2eb5acc8fa6f0d34b2eadd6e4cfcd9991a7b2d77932c4d7b1cd8bdd3471527ed2df765ea99830fa2df030646b5b653
DIST deja-dup-34.2.tar.xz 698788 SHA256 ff30732f28233e2422d069f1769a725d4a39c91a279c3bf885c4162fd85818bb SHA512 1c00026b5df53273916031cf72e4fc987d739b7985a9931641cef2afeff4b203e6bd2d9a97e255dd12a0de997d1fe9377c8b9106639312065a55a8206fcaa65f WHIRLPOOL 95c1200061ace9a09ac2309ba6253a608886c462e020da0cc9c14298392aab511b64dbb1aead6114e820408e5a366fa0e89d413fb11ab4daf692b63487d55420
75 changes: 75 additions & 0 deletions app-backup/deja-dup/deja-dup-34.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
GCONF_DEBUG="no"

inherit cmake-utils eutils gnome2 vala

DESCRIPTION="Simple backup tool using duplicity back-end"
HOMEPAGE="https://launchpad.net/deja-dup/"
SRC_URI="https://launchpad.net/${PN}/34/${PV}/+download/${P}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nautilus test"
RESTRICT="test"

COMMON_DEPEND="
app-admin/packagekit-base
app-crypt/libsecret[vala]
>=dev-libs/glib-2.34:2[dbus]
>=dev-libs/libpeas-1.0
>=x11-libs/gtk+-3.10:3
>=x11-libs/libnotify-0.7
>=app-backup/duplicity-0.6.23
dev-libs/dbus-glib
nautilus? ( gnome-base/nautilus )
"
RDEPEND="${COMMON_DEPEND}
gnome-base/dconf
gnome-base/gvfs[fuse]
"
DEPEND="${COMMON_DEPEND}
$(vala_depend)
app-text/yelp-tools
dev-perl/Locale-gettext
virtual/pkgconfig
dev-util/intltool
sys-devel/gettext
"

src_prepare() {
sed \
-e '/RPATH/s:PKG_LIBEXECDIR:PKG_LIBDIR:g' \
-i CMakeLists.txt || die
vala_src_prepare
gnome2_src_prepare
cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DVALA_EXECUTABLE="${VALAC}"
-DENABLE_CCPANEL=OFF
-DENABLE_PK=OFF
-DENABLE_UNITY=OFF
-DENABLE_UNITY_CCPANEL=OFF
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
$(cmake-utils_use_enable nautilus)
$(cmake-utils_use_enable test TESTING)
)
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
}

0 comments on commit fc4523c

Please sign in to comment.