Skip to content

Commit

Permalink
media-gfx/eog-plugins: Version bump to 3.26.8
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Jan 9, 2022
1 parent 590f306 commit fc49920
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/eog-plugins/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST eog-plugins-3.26.7.tar.xz 482336 BLAKE2B 9cd1d7e16f8e7f1fe06c3bc2ea79ab06c397beaf9d9bfb26568ad5fb90a144ceab11f6250c7dd51ebb5d3962fff47a4c855b85725b95abca07cdc4de739a2b7e SHA512 c9312eccc5529b01cb285a165c833243ea60bb12f8be6f40ccc6da0db1bd951916000a48aa31705b048659e8d637aa7e56d761fe0f9be720a4e0ce81289d2b83
DIST eog-plugins-3.26.8.tar.xz 479356 BLAKE2B ab781311473e045ffbb88e741427ac59f129fa53e6c551231d7b6edae81d21483dd1f1e7874561dfa29c9e9b2ba01fbdb174302bf8363478b785ec2ce38c53ec SHA512 a58aa849b09761dd0c7f7d31098560969872b03788f3f3ee81445dfb9be653b29e0e6646abc4e0164e4146abf7a9d2e6aadf56071f71c119493dcf1fd706a069
70 changes: 70 additions & 0 deletions media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{8..10} )

inherit gnome2 python-single-r1

DESCRIPTION="Eye of GNOME plugins"
HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="+exif map picasa +python"
REQUIRED_USE="
map? ( exif )
python? ( ${PYTHON_REQUIRED_USE} )
"

RDEPEND="
>=dev-libs/glib-2.38:2
>=dev-libs/libpeas-0.7.4:=
>=media-gfx/eog-3.15.90
>=x11-libs/gtk+-3.14:3
exif? ( >=media-libs/libexif-0.6.16 )
map? (
media-libs/libchamplain:0.12[gtk]
>=media-libs/clutter-1.9.4:1.0
>=media-libs/clutter-gtk-1.1.2:1.0 )
picasa? ( >=dev-libs/libgdata-0.9.1:= )
python? (
${PYTHON_DEPS}
>=dev-libs/glib-2.32:2[dbus]
dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
')
gnome-base/gsettings-desktop-schemas
media-gfx/eog[introspection]
x11-libs/gtk+:3[introspection]
x11-libs/pango[introspection] )
"
DEPEND="${RDEPEND}"
BDEPEND="
>=sys-devel/gettext-0.19.7
virtual/pkgconfig
"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_configure() {
local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
use exif && plugins="${plugins},exif-display"
use map && plugins="${plugins},map"
use picasa && plugins="${plugins},postasa"
use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
gnome2_src_configure \
$(use_enable python) \
--with-plugins=${plugins}
}

src_install() {
default
mv "${ED}"/usr/share/{appdata,metainfo}
find "${ED}" -type f -name "*.la" -delete || die
}

0 comments on commit fc49920

Please sign in to comment.