Skip to content

Commit

Permalink
mail-client/neomutt: Version bump to 2020-04-17
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Nicolas Bock <[email protected]>
  • Loading branch information
nicolasbock committed Apr 20, 2020
1 parent 08d128e commit fc7ebd6
Show file tree
Hide file tree
Showing 2 changed files with 129 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/neomutt/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST neomutt-20191129.tar.gz 3227652 BLAKE2B 50c598d83a53048cec14787b7b05a7e9e3d
DIST neomutt-20191207.tar.gz 3229018 BLAKE2B 44c3674d28abeef26614b1b05978417ffb2e4e1e88c7bd5902f0af87b5d06e9b9145a2d589258ccfec8de5e15f7b904ef309627a105c476a88328d698c16cbe9 SHA512 77faa95e6f6065a62c69814cae2c0dbc56083ec1d99524bedcec6672816223f2b6bd7e4478f916cf00e774a504fd73288857a9e79606ccf1a99601f29734c5f1
DIST neomutt-20200313.tar.gz 3295200 BLAKE2B 78d0f3a01f44c1bae8d3a99b86e799216e545674c5966364c347f8fc9ff0ef0b085ce44d0ade72e885b55ff47220d3931e22fe0b04a9cfbac639159a55377aa0 SHA512 989bff6e0748e76664ee0df8fa49f71d5c2ce7c9493441d9c080b34a5ddaef2870ec6aa665f8c2dbb290f16a578328efe92722f50389911cd9393181106a3116
DIST neomutt-20200320.tar.gz 3304719 BLAKE2B 5301a48f08857e390b204a62588895bb00623b4f82b58fb6a056b3f4e1ebe1476caf5b63c48ef175094245b69f2feac9fcf5b1d9c448a4875667a29037e46bba SHA512 6f47b29e2c941c3f47e3916f2fdb5e9a7cdac0221c88f9e5df1914cf6d28f7ae0ec63e0a20b271300771e073908714d2ab4c14646b617c26d48f91071ed344b2
DIST neomutt-20200417.tar.gz 3322435 BLAKE2B c0f4dc53d1f6c922c9d0bd77d5caf94d9b67db26ab88c9cb6409dc5e483b7d239bb1b66a473a95348a9bcef406ce7e47ffb9d7ea76098b06fb14f27b7cf941c5 SHA512 d23c2d72b6c783246e799fb14f9d2c6484580123766a33784fee065bdb23066a1178fd1ab0e1cc8d7f90d39a2a04950dcc70ed1a1d405676472fdc6e819dac17
128 changes: 128 additions & 0 deletions mail-client/neomutt/neomutt-20200417.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,128 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils flag-o-matic

if [[ ${PV} =~ 99999999$ ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neomutt/neomutt.git"
EGIT_CHECKOUT_DIR="${WORKDIR}/neomutt-${P}"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="A small but very powerful text-based mail client"
HOMEPAGE="https://neomutt.org/"

LICENSE="GPL-2"
SLOT="0"
IUSE="berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl
lmdb nls notmuch pgp-classic qdbm sasl selinux slang smime-classic
ssl tokyocabinet"

CDEPEND="
app-misc/mime-types
berkdb? (
|| (
sys-libs/db:6.2
sys-libs/db:5.3
sys-libs/db:4.8
)
<sys-libs/db-6.3:=
)
gdbm? ( sys-libs/gdbm )
kyotocabinet? ( dev-db/kyotocabinet )
lmdb? ( dev-db/lmdb )
nls? ( virtual/libintl )
qdbm? ( dev-db/qdbm )
tokyocabinet? ( dev-db/tokyocabinet )
gnutls? ( >=net-libs/gnutls-1.0.17 )
gpgme? ( >=app-crypt/gpgme-0.9.0 )
idn? ( net-dns/libidn:= )
kerberos? ( virtual/krb5 )
notmuch? ( net-mail/notmuch )
sasl? ( >=dev-libs/cyrus-sasl-2 )
!slang? ( sys-libs/ncurses:0 )
slang? ( sys-libs/slang )
ssl? (
!libressl? ( >=dev-libs/openssl-0.9.6:0 )
libressl? ( dev-libs/libressl )
)
"
DEPEND="${CDEPEND}
dev-lang/tcl
net-mail/mailbase
doc? (
dev-libs/libxml2
dev-libs/libxslt
app-text/docbook-xsl-stylesheets
|| ( www-client/lynx www-client/w3m www-client/elinks )
)"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-mutt )
"

src_configure() {
local myconf=(
"$(usex doc --full-doc --disable-doc)"
"$(use_enable nls)"
"$(use_enable notmuch)"

"$(use_enable gpgme)"
"$(use_enable pgp-classic pgp)"
"$(use_enable smime-classic smime)"

# Database backends.
"$(use_enable berkdb bdb)"
"$(use_enable gdbm)"
"$(use_enable kyotocabinet)"
"$(use_enable qdbm)"
"$(use_enable tokyocabinet)"

"$(use_enable idn)"
"$(use_enable kerberos gss)"
"$(use_enable lmdb)"
"$(use_enable sasl)"
"--with-ui=$(usex slang slang ncurses)"
"--sysconfdir=${EPREFIX}/etc/${PN}"
"$(use_enable ssl)"
"$(use_enable gnutls)"
)

econf CCACHE=none "${myconf[@]}"
}

src_install() {
emake DESTDIR="${D}" install

# A man-page is always handy, so fake one – here neomuttrc.5
# (neomutt.1 already exists)
if use !doc; then
sed -n \
-e '/^\(CC_FOR_BUILD\|CFLAGS_FOR_BUILD\)\s*=/p' \
-e '/^\(EXTRA_CFLAGS_FOR_BUILD\|LDFLAGS_FOR_BUILD\)\s*=/p' \
-e '/^\(EXEEXT\|SRCDIR\)\s*=/p' \
Makefile > doc/Makefile.fakedoc || die
sed -n \
-e '/^MAKEDOC_CPP\s*=/,/^\s*$/p' \
-e '/^doc\/\(makedoc$(EXEEXT)\|neomutt\.1\|neomuttrc\.5\)\s*:/,/^\s*$/p' \
doc/Makefile.autosetup >> doc/Makefile.fakedoc || die
emake -f doc/Makefile.fakedoc doc/neomutt.1
emake -f doc/Makefile.fakedoc doc/neomuttrc.5
doman doc/neomutt.1 doc/neomuttrc.5
fi

dodoc LICENSE* ChangeLog* README*
}

pkg_postinst() {
if use gpgme && ( use pgp-classic || use smime-classic ); then
ewarn " Note that gpgme (old gpg) includes both pgp and smime"
ewarn " support. You can probably remove pgp-classic (old crypt)"
ewarn " and smime-classic (old smime) from your USE-flags and"
ewarn " only enable gpgme."
fi
}

0 comments on commit fc7ebd6

Please sign in to comment.