Skip to content

Commit

Permalink
dev-ada/libgpr: version bump to 2020
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Jun 12, 2020
1 parent dd2d8d6 commit fca3b04
Show file tree
Hide file tree
Showing 3 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ada/libgpr/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gprbuild-2019-20190517-194D8-src.tar.gz 2507961 BLAKE2B 0f70d94cb0db9ddc1dd308862aaa305a91965a62a936cfbdde2ae9f3f735f0cc3d69596b09da4b979a1d7923087ab0ec5cf2d6541551f057b5e8e0c499065a90 SHA512 0388d7e6cdf625fef40b33da764091b3283dd88714c64ecfad4b5e99253f183b1a9b717c19281e6d45cc4277a05fadb2e2ace394d6f30638664b66c97123052b
DIST gprbuild-2020-20200429-19BD2-src.tar.gz 2489399 BLAKE2B 3a036cb40bbe5522af63c376a672384093901b44df6fd74013f1eff9d269c2f5056224ab5e7d59b6f3cf126cd14dd30420056b09e887851351462de59f700e3a SHA512 d2ff6a5d8281d332a31533c7a5744b6169fd250c9086373fd658486c1e529564d9830b9ef3b2dfcbec5f8c1ba50d244a9eb45bf8fdccd53f8b711dcf29258dfd
11 changes: 11 additions & 0 deletions dev-ada/libgpr/files/libgpr-2020-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/gpr/src/gpr-env.adb 2017-11-13 22:16:53.349083426 +0100
+++ b/gpr/src/gpr-env.adb 2017-11-13 22:17:22.692590351 +0100
@@ -1948,6 +1948,8 @@

end if;

+ Add_Directories (Self, "/usr/share/gpr");
+
if Gpr_Prj_Path.all /= "" then
Add_Directories (Self, Gpr_Prj_Path.all);
end if;
66 changes: 66 additions & 0 deletions dev-ada/libgpr/libgpr-2020.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ADA_COMPAT=( gnat_201{6,7,8,9} )
inherit ada toolchain-funcs multiprocessing

MYP=gprbuild-${PV}-20200429-19BD2-src

DESCRIPTION="Ada library to handle GPRbuild project files"
HOMEPAGE="http://libre.adacore.com/"
SRC_URI="https://community.download.adacore.com/v1/408ec35c3bb86bd227db3da55d3e1e0c572a56e3?filename=${MYP}.tar.gz
-> ${MYP}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+shared static-libs static-pic"

RDEPEND="dev-ada/xmlada[shared?,static-libs?,static-pic?,${ADA_USEDEP}]
!net-libs/grpc"
DEPEND="${RDEPEND}
dev-ada/gprbuild[${ADA_USEDEP}]"
REQUIRED_USE="${ADA_REQUIRED_USE}"

QA_FLAGS_IGNORED=(
/usr/lib/gpr/relocatable/gpr/libgpr.so
)

S="${WORKDIR}"/${MYP}

PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )

src_configure() {
emake prefix="${D}"/usr setup
}

src_compile() {
build () {
gprbuild -p -m -j$(makeopts_jobs) -XBUILD=production -v \
-XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$1 \
gpr/gpr.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
}
if use shared; then
build relocatable
fi
if use static-libs; then
build static
fi
if use static-pic; then
build static-pic
fi
}

src_install() {
if use static-libs; then
emake DESTDIR="${D}" libgpr.install.static
fi
for kind in shared static-pic; do
if use ${kind}; then
emake DESTDIR="${D}" libgpr.install.${kind}
fi
done
rm -r "${D}"/usr/share/gpr/manifests || die
einstalldocs
}

0 comments on commit fca3b04

Please sign in to comment.