Skip to content

Commit

Permalink
net-misc/i2pd: version bump 2.11.0
Browse files Browse the repository at this point in the history
  • Loading branch information
khumarahn authored and blueness committed Dec 20, 2016
1 parent b02e839 commit fcb1ce4
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/i2pd/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
DIST i2pd-2.10.0.tar.gz 2985581 SHA256 614d746e4d0b13433de56eb0492a6a4aa36a5b43ab88f12429ed5bd20baa78a0 SHA512 61c0b75327ca031afb879ae32ddc5ce871a7ba5c7705a127d1575d5fd7d8b0ee496363e57f6ed6857ac758bc2ed525f43ad2a369805c0f35e22b9ce9020c9dbe WHIRLPOOL 10963d0857b169d0e76ac02be5a8c9530fc908554216d6d55195fe91fc71ad1740cb9cfd33cbe4dee8e4b7d7bd2a9b895e63516f67f980012b9446498584f16a
DIST i2pd-2.10.1.tar.gz 2993590 SHA256 84d3890ea9f381884deaeaf3154f945519f9a9f77d363e606f6408ea6d682631 SHA512 0b5a51606507e86070f4fdeba2b649f71fd7d74f9ee9d0d52dba67dbe0e89aceef04972d0e8b7c59304a4cb610ba65f90e2f3704dc59b6ce6199eddddaa9ca3a WHIRLPOOL d5a04c49060c750cde9a017b2739cc5adb8449afcf91105c2c290744447b57508e75bdddb3237d0c2a0c1984a704b37f32bfeb76b71aad287edb05c2b52eb8e8
DIST i2pd-2.10.2.tar.gz 3090874 SHA256 9d1f8dd33f537ad629fc69f0ccfa4cde22ca5023981a9c5b6acd5d551b9c7b8b SHA512 5bdce54eccdf92ed46cbef3e29c3f8750755042a4060361831a9239929d04c055848f2ea5263686eca849dbae55bb52342d96008fb61b04fd1883f21a94c425a WHIRLPOOL 7f92f68232ee29ca194a05cc152496722224345d1a9a32fd57fd9b49f8ec318383f9345c54319ec78bed407251f9ada4052057f867a40353189234da9f9a56b8
DIST i2pd-2.11.0.tar.gz 3091516 SHA256 4d7946e33a6a1dd4439590ea23b494f36e6fbcb81f7b36857bf264413a19e9db SHA512 c4964c23f6852e6ce225de6f6f03ce4e5c52a6ec2b925b82c01be574b14196112079ada5864b10f353c3dd385645db550d5ce290647b6d980225a79c64f19ddb WHIRLPOOL f2a4c42ad2df09188b5be8fad23f7f2ec2080e17b980b55c1647c13499c6b3cce88d6e9c2fbfd34bf8783a0b52c15659775351835ae181e58357c455ebb1dea1
DIST i2pd-2.8.0.tar.gz 1695271 SHA256 3f3f538b3c5b3095021311b434456c42d6f3b5e43dc7972c263b10ef179ba063 SHA512 379b72c4021dc8342405a034219ecb3681014a0ea1612da8b61de2b03adf2611ebe267233ed2891a2fb5a345d9304d7501c42d8c985362be72239b653d0d3c39 WHIRLPOOL 511d4e3a084604289c041a69135d8afc5abca186fe96704ca35108e96c84523706aaa73c07884dcce65df1fe9fed9335cea65b52dc14bd4a61b94d6fd11c6838
DIST i2pd-2.9.0.tar.gz 2967757 SHA256 48139f83352f26023b99d7d6ee49e648febd2a8db6beb88c108facaf46a282e2 SHA512 6d5f2c1b6b68a0dab3171c6dfe02ce4bbe4afd273a8ff1f93870813c7ad5728334b54f9ff0c91eb2be82249b88d40479bc0dd33b494562973a6a1239e3be65c9 WHIRLPOOL 3d1eaf3c09e9b0490c82198643e2a7f763885887c1a72b6a97105b7cc03c554093920b8739df74bb44b74850172a61963981d9b548d85be898c1124a6af9a5a7
99 changes: 99 additions & 0 deletions net-misc/i2pd/i2pd-2.11.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils systemd user cmake-utils

DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="cpu_flags_x86_aes i2p-hardening libressl pch static +upnp"

RDEPEND="!static? ( >=dev-libs/boost-1.49[threads]
!libressl? ( dev-libs/openssl:0[-bindist] )
libressl? ( dev-libs/libressl )
upnp? ( net-libs/miniupnpc )
)"
DEPEND="${RDEPEND}
static? ( >=dev-libs/boost-1.49[static-libs,threads]
!libressl? ( dev-libs/openssl:0[static-libs] )
libressl? ( dev-libs/libressl[static-libs] )
upnp? ( net-libs/miniupnpc[static-libs] ) )
i2p-hardening? ( >=sys-devel/gcc-4.7 )
|| ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 )"

I2PD_USER=i2pd
I2PD_GROUP=i2pd

CMAKE_USE_DIR="${S}/build"

DOCS=( README.md docs/i2pd.conf docs/tunnels.conf )

PATCHES=( "${FILESDIR}/${PN}-2.5.1-fix_installed_components.patch" )

src_configure() {
mycmakeargs=(
-DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
-DWITH_HARDENING=$(usex i2p-hardening ON OFF)
-DWITH_PCH=$(usex pch ON OFF)
-DWITH_STATIC=$(usex static ON OFF)
-DWITH_UPNP=$(usex upnp ON OFF)
-DWITH_LIBRARY=ON
-DWITH_BINARY=ON
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install

# config
insinto /etc/i2pd
doins docs/i2pd.conf
doins docs/tunnels.conf

# grant i2pd group read and write access to config files
fowners "root:${I2PD_GROUP}" \
/etc/i2pd/i2pd.conf \
/etc/i2pd/tunnels.conf
fperms 660 \
/etc/i2pd/i2pd.conf \
/etc/i2pd/tunnels.conf

# working directory
keepdir /var/lib/i2pd
insinto /var/lib/i2pd
doins -r contrib/certificates
fowners "${I2PD_USER}:${I2PD_GROUP}" /var/lib/i2pd/
fperms 700 /var/lib/i2pd/

# add /var/lib/i2pd/certificates to CONFIG_PROTECT
doenvd "${FILESDIR}/99i2pd"

# openrc and systemd daemon routines
newconfd "${FILESDIR}/i2pd-2.6.0-r3.confd" i2pd
newinitd "${FILESDIR}/i2pd-2.6.0-r3.initd" i2pd
systemd_newunit "${FILESDIR}/i2pd-2.6.0-r3.service" i2pd.service

# logrotate
insinto /etc/logrotate.d
newins "${FILESDIR}/i2pd-2.6.0-r3.logrotate" i2pd
}

pkg_setup() {
enewgroup "${I2PD_GROUP}"
enewuser "${I2PD_USER}" -1 -1 /var/lib/run/i2pd "${I2PD_GROUP}"
}

pkg_postinst() {
if [[ -f ${EROOT%/}/etc/i2pd/subscriptions.txt ]]; then
ewarn
ewarn "Configuration of the subscriptions has been moved from"
ewarn "subscriptions.txt to i2pd.conf. We recommend updating"
ewarn "i2pd.conf accordingly and deleting subscriptions.txt."
fi
}

0 comments on commit fcb1ce4

Please sign in to comment.