Skip to content

Commit

Permalink
dev-ruby/slim: add 3.0.9
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
graaff committed Nov 10, 2017
1 parent 61a1496 commit fce9792
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/slim/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST slim-3.0.7.gem 97280 SHA256 1747e293c161fdb21547f27b2eb585af26c19baa3110866a28e10d3b05ab5088 SHA512 b410ed35941a3cfc68f8ab5649450381f830f94c8503e062afcd097f5a669df4cf8035d0baefd42bffaad5d12766baf70bad3eed82149fd861f615649ee469c0 WHIRLPOOL 941e29de5ef4d9a8e720e98ed65b6992089b954f9991b4f9481b977d0f9eac295d9f07374403c5875a9a22ebc2687fe13e66e6808f17e0ad69f5686f029d9300
DIST slim-3.0.8.gem 99328 SHA256 5f6e5cffd9ef1404544d756bb224c5b1395a71043306d427b23497c67be297eb SHA512 c9ed748c221f1bc25f3442900e93db6674520388c8d958bb40516172b97da042cd2e20fd924f9c85382b08eb39e399ae675c4d4e0b1d884ceef7339697345dd4 WHIRLPOOL 05c55e8f34d0100c7fdc80ce3a155eefe980a4e42ef43c6f2283b6bb64084dc53015388cffb67eb36b8404a19568417f46788d3a7a9cec479764b7ad6a6f3d65
DIST slim-3.0.9.gem 99840 SHA256 74df41b42bf4cfed22dd2524dba203a9621718ce7fba1b54cdd42edd07029f7f SHA512 220dbcde230aab05e294022924346fbb02a1bf813a7c97910c2f60d7b3a7dd498d04f6f4f2883b895d2a3e6e9f526331914e3ab4560e748de2bd991358cca90d WHIRLPOOL 72b5d567176091dca63af842924689fa226ff429dfc3ac36dc4a3b32bbfc5783a1f8c244bf04a8e9af609a56eafd95b29d1473ea6346b30519d8542146f02507
50 changes: 50 additions & 0 deletions dev-ruby/slim/slim-3.0.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby22 ruby23 ruby24"

RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_TASK_DOC="yard"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="A template language aiming to reduce the syntax to the essential parts"
HOMEPAGE="http://slim-lang.com/"
LICENSE="MIT"

KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
SLOT="0"
IUSE="doc"

ruby_add_rdepend ">=dev-ruby/tilt-1.3.3:* <dev-ruby/tilt-2.1:*
>=dev-ruby/temple-0.7.6:0.7"

ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/redcarpet )"

ruby_add_bdepend "test? ( dev-ruby/sass )"

all_ruby_prepare() {
sed -i -e '/bundler/I s:^:#:' Rakefile || die

# This sinatra code expects tests to be installed but we strip those.
sed -i -e "s/require 'sinatra'/require 'bogussinatra'/" Rakefile || die

# Avoid tests for things we don't have. The builder test does not pass with tilt 2.x
sed -i -e '/test_wip_render_with_asciidoc/,/^ end/ s:^:#:' \
-e '/test_render_with_wiki/,/^ end/ s:^:#:' \
-e '/test_render_with_creole/,/^ end/ s:^:#:' \
-e '/test_render_with_builder/,/^ end/ s:^:#:' \
-e '/test_render_with_org/,/^ end/ s:^:#:' test/core/test_embedded_engines.rb || die

sed -i -e '/s\.files/ s/git ls-files/find . -type f -print/' \
-e '/s\.executables/ s:git ls-files -- bin/\*:find bin -type f -print:' ${RUBY_FAKEGEM_GEMSPEC} || die
}

each_ruby_prepare() {
sed -i -e '/Open3/ s:ruby:'${RUBY}':' test/core/test_commands.rb || die
}

0 comments on commit fce9792

Please sign in to comment.