Skip to content

Commit

Permalink
dev-lang/nqp: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
patricklauer committed Feb 23, 2016
1 parent f817903 commit fced318
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/nqp/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST nqp-2016.01.tar.gz 5117110 SHA256 87875120af7167093643f2a35869d66a61f735220a9348627ba89cf294387c8b SHA512 e79668f7f5f3679fe3b93f63e1151da1eab109ef4acc6f8ae3da3d9e5c3da814440dd43279978b1a13f30647d7c52bda5575b02f366bd928965b06b47c6d6d91 WHIRLPOOL d2369417707332d8bc045f6f93da81e1301ec2599f197664d80e6edeefc1bc7a2147ad3b7e893eef0fb6b96adf2f68f5ab44b948801e266e68d99552253abeda
DIST nqp-2016.02.tar.gz 5121833 SHA256 051ddd4bab8f73a688836d896340320ff7043a6ecbd5c53be099249e75e33b8d SHA512 9a3233e351ebdf73ed27d3eade2052936d1a49ea95d32a8176e426e7126c720e4a3f69dedc4067925272293329b08ab397f6a7523b9e4129952847fbd86fcf0d WHIRLPOOL 1bad2dc420d59f07c3d9b8d9dcc78d51a772ed2672419fc53e427c68e24fce5645a0dcfd4a4e138e6333f9e909297b49fafe190e6dc763cca8e52dce20309ec5
64 changes: 64 additions & 0 deletions dev-lang/nqp/nqp-2016.02.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

# still not working
RESTRICT="test"

inherit eutils multilib versionator

GITCRAP=1d6b8cb

DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
HOMEPAGE="http://rakudo.org/"
SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"

LICENSE="Artistic-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="doc java +moar"
REQUIRED_USE="|| ( java moar )"

RDEPEND="
java? ( >=virtual/jre-1.7 )
moar? ( ~dev-lang/moarvm-${PV} )
dev-libs/libffi"
DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.7 )
dev-lang/perl"

S=${WORKDIR}/perl6-nqp-${GITCRAP}

src_configure() {
use java && myconf+="jvm,"
use moar && myconf+="moar,"
perl Configure.pl --backend=${myconf} --prefix=/usr || die
# dirty hack to make dyncall not fail
sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
sed -i -e 's/-Werror=missing-declarations//' Makefile || die
sed -i -e 's/-Werror=strict-prototypes//' Makefile || die

# more dirty hack to allow building with newer gcc
sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
sed -i -e 's/-Werror=nested-externs//' Makefile || die
}

src_compile() {
emake -j1 || die
}

src_test() {
emake -j1 test || die
}

src_install() {
emake DESTDIR="${ED}" install || die

dodoc CREDITS README.pod || die

if use doc; then
dodoc -r docs/* || die
fi
}

0 comments on commit fced318

Please sign in to comment.