Skip to content

Commit

Permalink
games-action/towbowl-tactics: port to EAPI 7, games.eclass--
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 5, 2021
1 parent 7291245 commit fd2c42c
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 23 deletions.
Original file line number Diff line number Diff line change
@@ -1,16 +1,14 @@
diff -ru tbt.orig/config.xml tbt/config.xml
--- tbt.orig/config.xml 2003-02-01 15:14:56.000000000 -0500
+++ tbt/config.xml 2011-01-10 12:08:01.564649048 -0500
--- a/config.xml
+++ b/config.xml
@@ -5,5 +5,5 @@
<screen_h>600</screen_h>
<sound_enabled>1</sound_enabled>
<video_enabled>1</video_enabled>
-<language>0</language>
+<language>1</language>
</config>
diff -ru tbt.orig/src/Makefile tbt/src/Makefile
--- tbt.orig/src/Makefile 2003-02-01 15:07:40.000000000 -0500
+++ tbt/src/Makefile 2011-01-10 12:07:29.075274834 -0500
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,24 +1,20 @@
TBTHOME = /usr/local/games/tbt
INCDIR = -I /usr/include/smpeg -I /usr/include/libxml2 -I /usr/include/SDL/
Expand Down
Original file line number Diff line number Diff line change
@@ -1,51 +1,64 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit eutils games
EAPI=7

inherit desktop edos2unix toolchain-funcs

DESCRIPTION="Tow Bowl Tactics is a game based on Games Workshop's Blood Bowl"
HOMEPAGE="http://www.towbowltactics.com/index_en.html"
SRC_URI="http://www.towbowltactics.com/download/tbt.${PV}.src.zip"
S="${WORKDIR}"/tbt/src

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="dev-libs/libxml2
RDEPEND="
dev-libs/libxml2
media-libs/smpeg
media-libs/libsdl[sound,video]
media-libs/sdl-net
media-libs/sdl-image[jpeg,png]
media-libs/sdl-mixer"
DEPEND="${RDEPEND}
app-arch/unzip"
DEPEND="${RDEPEND}"
BDEPEND="app-arch/unzip"

S=${WORKDIR}/tbt/src
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
)

src_prepare() {
cd ..
cd .. || die

edos2unix $(find src -type f) config.xml
epatch "${FILESDIR}"/${P}-gentoo.patch

default

sed -i \
-e "/^TBTHOME/ s:/.*:${GAMES_DATADIR}/tbt:" \
-e "/^TBTHOME/ s:/.*:/usr/share/tbt:" \
src/Makefile || die
sed -i \
-e "/tbt.ico/ s:\"\./:TBTHOME \"/:" \
src/Main.cpp || die
sed -i \
-e "s:TBTHOME \"/config.xml:\"${GAMES_SYSCONFDIR}/tbt/config.xml:g" \
-e "s:TBTHOME \"/config.xml:\"/etc/tbt/config.xml:g" \
src/global.h || die
}

src_configure() {
tc-export CXX
}

src_install() {
dogamesbin tbt
dodir "${GAMES_DATADIR}/tbt"
cp -r ../data ../tbt.ico "${D}${GAMES_DATADIR}/tbt" || die
insinto "${GAMES_SYSCONFDIR}/tbt"
dobin tbt

dodir /usr/share/tbt
cp -r ../data ../tbt.ico "${ED}"/usr/share/tbt || die

insinto /etc/tbt
doins ../config.xml

newicon ../data/images/panel/turn.png ${PN}.png
make_desktop_entry tbt "Tow Bowl Tactics"
prepgamesdirs
}

0 comments on commit fd2c42c

Please sign in to comment.