Skip to content

Commit

Permalink
dev-perl/wxperl: Support wxGTK:3.0 (#563340)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
pacho2 committed Oct 24, 2015
1 parent e1d29ba commit fd33aee
Showing 1 changed file with 46 additions and 0 deletions.
46 changes: 46 additions & 0 deletions dev-perl/wxperl/wxperl-0.992.700-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

MY_PN=Wx
WX_GTK_VER="3.0"
MODULE_AUTHOR=MDOOTSON
MODULE_VERSION=0.9927
inherit wxwidgets virtualx perl-module

DESCRIPTION="Perl bindings for wxGTK"
HOMEPAGE="http://wxperl.sourceforge.net/ ${HOMEPAGE}"

SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="
>=dev-perl/Alien-wxWidgets-0.670.0
x11-libs/wxGTK:${WX_GTK_VER}
>=virtual/perl-File-Spec-0.820.0
"
DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.480.0
>=virtual/perl-ExtUtils-ParseXS-3.150.0
>=dev-perl/ExtUtils-XSpp-0.160.200
>=virtual/perl-if-0.30.0
test? (
>=virtual/perl-Test-Harness-2.260.0
>=virtual/perl-Test-Simple-0.430.0
)
"

src_prepare() {
need-wxwidgets base-unicode
perl-module_src_prepare
}

src_test() {
VIRTUALX_COMMAND=perl-module_src_test
virtualmake
}

SRC_TEST="do"

0 comments on commit fd33aee

Please sign in to comment.