Skip to content

Commit

Permalink
app-admin/ansible-lint: add 6.14.3
Browse files Browse the repository at this point in the history
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Mar 25, 2023
1 parent 6761ed2 commit fd4800a
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/ansible-lint/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ansible-lint-6.12.1.tar.gz 466371 BLAKE2B f43b3403c5d3db80d3ec3e3526cafc22bee68b31b5458e378a73bbec900de5411c597e9fc079a77cffc66a278a37bf0fc9ecfcaba3beccf74c6eecbe5b6148b9 SHA512 05c92c930d91419c212a9513aed5506c99e993acbce9437b6f8f3b95bd78ca5b0ff8e1a7d39f32907df72d858a2e4e6c74f47443c0f937b3644c7a18d1d59252
DIST ansible-lint-6.14.2.tar.gz 473090 BLAKE2B 7ee73ab0b9539ae56cdf0220d79b271c45747fc1379f818e14f99b0d361e87cd7410548261e369a1d90cb3dceeb53bd46d614b041c837253ef643b653430bf51 SHA512 bb7350b56b9f81d398509b612cf1631020c21bed4f08ea8dda482460c18a1c0388269af513833778f29f1003a114366af885e7b7f31149731bad2067a904d30a
DIST ansible-lint-6.14.3.tar.gz 474969 BLAKE2B ea32928ccb27750bfa410907cdf03b8b5bd29cafafe04615782b06705ef540e5d7f92fafdb824bbf86337d4a4b63e377362fb758d59a7942c7891a1d80a94762 SHA512 a8dcc8ba7920da141f235a9b70156a3d65f45ac335511a6caf708c81b29f47fcde38cc02a9e1eedb1cb70643c98a0a9d92218b7723da94319b2a220ee181868c
55 changes: 55 additions & 0 deletions app-admin/ansible-lint/ansible-lint-6.14.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..11} )

inherit distutils-r1 pypi

DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
HOMEPAGE="https://github.com/ansible/ansible-lint"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"

# Upstream has stated explicitly that all tests require Internet access
PROPERTIES="test_network"
RESTRICT="test"

RDEPEND="
>=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
>=dev-python/ansible-compat-2.2.7[${PYTHON_USEDEP}]
>=dev-python/black-22.8.0[${PYTHON_USEDEP}]
>=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
>=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
>=dev-python/packaging-21.3[${PYTHON_USEDEP}]
>=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
>=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
>=dev-python/ruamel-yaml-0.17.21[${PYTHON_USEDEP}]
>=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
>=dev-util/yamllint-1.26.3[${PYTHON_USEDEP}]
dev-vcs/git"
BDEPEND="
>=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
>=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
>=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
)"

# test_call_from_outside_venv doesn't play nicely with the sandbox
# irrespective of whether Internet access is allowed or not
EPYTEST_DESELECT=(
test/test_main.py::test_call_from_outside_venv
)

distutils_enable_tests pytest

# Test suite fails to start without this
python_test() {
epytest test
}

0 comments on commit fd4800a

Please sign in to comment.